aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gettext.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 5956742bbb..886175e17e 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -199,12 +199,14 @@ color, font attributes (weight, posture), or underlining.")
`(#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-programs
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure all executables in "bin" find the Perl modules
- ;; provided by this package at runtime.
+ ;; required by this package at runtime.
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin/"))
- (path (string-append out "/lib/perl5/site_perl")))
+ (Pod::Parser (assoc-ref inputs "perl-pod-parser"))
+ (path (string-append out "/lib/perl5/site_perl:"
+ Pod::Parser "/lib/perl5/site_perl")))
(for-each (lambda (file)
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
@@ -224,6 +226,13 @@ color, font attributes (weight, posture), or underlining.")
(string-append (assoc-ref inputs "docbook-xml")
"/xml/dtd/docbook/")))
#t))
+ (add-before 'build 'do-not-override-PERL5LIB
+ (lambda _
+ ;; Don't hard-code PERL5LIB to include just the build directory
+ ;; so that the build script finds modules from inputs.
+ (substitute* "Po4aBuilder.pm"
+ (("PERL5LIB=lib") ""))
+ (setenv "PERL5LIB" (string-append (getenv "PERL5LIB") ":lib"))))
(add-before 'check 'disable-failing-tests
(lambda _
;; FIXME: these tests require SGMLS.pm.
@@ -247,6 +256,8 @@ color, font attributes (weight, posture), or underlining.")
("perl-test-pod" ,perl-test-pod)
("perl-yaml-tiny" ,perl-yaml-tiny)
("texlive" ,texlive-tiny)))
+ (inputs
+ `(("perl-pod-parser" ,perl-pod-parser)))
(home-page "https://po4a.org/")
(synopsis "Scripts to ease maintenance of translations")
(description
ls.scm?id=0ce611f56397092ac963efac71be3d509f035733'>gnu: Add python-defcon....* gnu/packages/fontutils.scm (python-defcon): New variable. (python2-defcon): Adjust to inherit from it. Maxim Cournoyer 2022-05-12gnu: Add python-fontpens....* gnu/packages/fontutils.scm (python-fontpens): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-fontparts-bootstrap....* gnu/packages/fontutils.scm (python-fontparts-bootstrap): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-fontpens-bootstrap....* gnu/packages/fontutils.scm (python-fontpens-bootstrap): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-mutatormath....* gnu/packages/fontutils.scm (python-mutatormath): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-fontmath....* gnu/packages/fontutils.scm (python-fontmath): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-defcon-bootstrap....* gnu/packages/fontutils.scm (python-defcon-bootstrap): New variable. Maxim Cournoyer 2022-05-12gnu: Add python-opentype-sanitizer....* gnu/packages/fontutils.scm (python-opentype-sanitizer): New variable. Maxim Cournoyer 2022-05-12gnu: Add opentype-sanitizer....* gnu/packages/fontutils.scm (opentype-sanitizer): New variable. Maxim Cournoyer 2022-04-12gnu: woff2: Propagate brotli....* gnu/packages/fontutils.scm (woff2)[phases]: Delete trailing #t. [inputs]: Move brotli to ... [propagated-inputs]: ... here. Maxim Cournoyer 2022-02-23gnu: fontutils: Add gsettings-desktop-schemas....* gnu/packages/fontutils.scm (fontmanager)[inputs]: Add gsettings-desktop-schemas. Maxim Cournoyer 2022-02-15gnu: fcft: Update to 3.0.1...* gnu/packages/fontutils.scm (fcft): Update to 3.0.1. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Felipe Balbi 2022-01-31gnu: fontmanager: Add missing input....* gnu/packages/fontutils.scm (fontmanager)[native-inputs]: Add python-wrapper. Julien Lepiller 2021-12-14gnu: fontmanager: Use libsoup2 and vala-0.52...These changes fix the build. * gnu/packages/fontutils.scm (fontmanager)[native-inputs]: Replace vala with vala-0.52. [inputs]: Replace libsoup with libsoup-minimal-2. Replace webkitgtk with webkitgtk-with-libsoup2. Signed-off-by: Leo Famulari <leo@famulari.name> Josselin Poiret via Guix-patches via 2021-12-14gnu: libraqm: Update to 0.8.0....* gnu/packages/fontutils.scm (libraqm): Update to 0.8.0. Nicolas Goaziou 2021-12-14gnu: fcft: Update to 2.5.1....* gnu/packages/fontutils.scm (fcft): Update to 2.5.1. [native-inputs]: Remove GCC-10. Marius Bakke 2021-12-13gnu: Further simplify package inputs....This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.) Ludovic Courtès 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-11gnu: fontconfig: Add a search path for XDG_DATA_DIRS....Fixes <https://issues.guix.gnu.org/31403>. * gnu/packages/fontutils.scm (fontconfig)[source]: Fix indentation. [configure-flags]: Drop the "--with-add-fonts" configure option as it's no longer necessary/desirable to special case the system and user profiles. [native-search-paths]: New search path. Maxim Cournoyer 2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-10-26gnu: fcft: Update to 2.4.6....* gnu/packages/fontutils.scm (fcft): Update to 2.4.6. Tobias Geerinckx-Rice 2021-10-23gnu: fontmanager: Update to 0.8.7....* gnu/packages/fontutils.scm (fontmanager): Update to 0.8.7. Tobias Geerinckx-Rice 2021-10-21gnu: fntsample: Update to 5.4....* gnu/packages/fontutils.scm (fntsample): Update to 5.4. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-10-21gnu: fntsample: Update Blocks.txt and use stable URL....* gnu/packages/fontutils.scm (fntsample)[input]: Update unicode-blocks to 14.0.0 and include the version in its URL and name. Tobias Geerinckx-Rice 2021-10-14Merge branch 'master' into core-updates-frozenMarius Bakke