aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3db657f0db..846860f440 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2570,14 +2570,14 @@ you about the changes.")
(define-public ruby-activesupport
(package
(name "ruby-activesupport")
- (version "5.1.3")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "activesupport" version))
(sha256
(base32
- "16r18n6b1nlky0xx2lw8c1f15gr2vm34xz5g4byjcxf88m1s07xh"))))
+ "0sgf4rsfr7jcaqsx0wwzx4l4k9xsjlwv0mzl08pxiyp1qzyx8scr"))))
(build-system ruby-build-system)
(arguments
`(#:phases
f855ba6'>gnu: Use 'install-file' instead of 'mkdir-p' and 'copy-file' in obvious cases....* gnu/packages/bioinformatics.scm (bedtools, bowtie, bwa, hisat, samtools, plink, star): Use 'install-file' instead of 'mkdir-p' + 'copy-file'. * gnu/packages/check.scm (catch-framework): Likewise. * gnu/packages/code.scm (global): Likewise. * gnu/packages/emacs.scm (magit-svn, haskell-mode, emacs-pdf-tools): Likewise. * gnu/packages/engineering.scm (fastcap, fasthenry): Likewise. * gnu/packages/gnuzilla.scm (nss): Likewise. * gnu/packages/guile.scm (guile-minikanren): Likewise. * gnu/packages/java.scm (swt): Likewise. * gnu/packages/make-bootstrap.scm (%static-binaries): Likewise. * gnu/packages/maths.scm (lpsolve): Likewise. * gnu/packages/mp3.scm (mpc123): Likewise. * gnu/packages/ninja.scm (ninja): Likewise. * gnu/packages/python.scm (python-numpy, python-pyparsing): Likewise. * gnu/packages/screen.scm (dtach): Likewise. * gnu/packages/synergy.scm (synergy): Likewise. * gnu/packages/textutils.scm (utf8proc): Likewise. * gnu/packages/version-control.scm (git-test-sequence): Likewise. * gnu/packages/wicd.scm (wicd): Likewise. Ludovic Courtès 2015-07-14gnu: Build tarballs deterministically....* gnu/packages/make-bootstrap.scm (tarball-package)[arguments]: Build tarball deterministically. * gnu/packages/admin.scm (isc-dhcp)[arguments]: In 'post-configure' phase, create bind.tar.gz deterministically. * gnu/packages/video.scm (avidemux)[arguments]: In 'repack-ffmpeg' phase, create ffmpeg-1.2.1.tar.bz2 deterministically. Mark H Weaver 2015-06-26gnu: Refer to 'gcc' instead of 'gcc-4.9'....* gnu/packages/commencement.scm (gcc-boot0, cross-gcc-wrapper, libstdc++, gcc-final): Refer to GCC instead of GCC-4.9. * gnu/packages/cross-base.scm (%xgcc): New variable. (cross-gcc-arguments, cross-gcc): Refer to %XGCC instead of GCC-4.9. * gnu/packages/llvm.scm (clang-from-llvm): Refer to GCC instead of GCC-4.9. * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc, %gcc-static, %gcc-stripped): Likewise. Ludovic Courtès 2015-06-15gnu: make-bootstrap: Build libbacktrace, required by cc1....Fixes <http://hydra.gnu.org/build/506982/nixlog/1/tail-reload>. * gnu/packages/make-bootstrap.scm (%gcc-static): Remove --disable-libbacktrace. It is needed by cc1-checksum. Ludovic Courtès 2015-06-15gnu: make-bootstrap: Update patching of gawk's configure....* gnu/packages/make-bootstrap.scm (%static-inputs)[gawk]: Change "-export-dynamic" to "-Wl,-export-dynamic" to account for current 'configure' file. Ludovic Courtès 2015-06-15gnu: make-bootstrap: Switch to GCC 4.9....* gnu/packages/make-bootstrap.scm: Replace all occurrences of "gcc-4.8" with "gcc-4.9". (%gcc-static): Add --disable-libcilkrts, --disable-libvtv, --disable-libbacktrace. Ludovic Courtès 2015-06-14Merge branch 'master' into core-updates...Conflicts: gnu/packages/commencement.scm gnu/packages/xml.scm Mark H Weaver 2015-06-11packages: Make 'location' field innate....* guix/packages.scm (<package>)[location]: Add 'innate' property. * guix/build-system/gnu.scm (static-package): Remove 'loc' parameter and 'location' field. * gnu/packages/autotools.scm (autoconf-wrapper): Remove 'location' field. * gnu/packages/commencement.scm (gnu-make-boot0, diffutils-boot0, gcc-final): Likewise. * gnu/packages/cross-base.scm (cross): Likewise. * gnu/packages/emacs.scm (emacs-no-x, emacs-no-x-toolkit): Likewise. * gnu/packages/make-bootstrap.scm (tarball-package): Likewise. * gnu/packages/maths.scm (petsc-complex): Likewise. Ludovic Courtès 2015-06-04gnu: linux-libre-headers: Do not retain reference to the bootstrap tools....* gnu/packages/linux.scm (linux-libre-headers)[install-phase]: Remove ".install" files from the output. [arguments]: Add #:allowed-references. Ludovic Courtès