aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ftp.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 5ff56d7eae..7380fcfc3b 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -36,23 +36,19 @@
(define-public lftp
(package
(name "lftp")
- (version "4.7.4")
+ (version "4.7.5")
(source (origin
(method url-fetch)
- ;; XXX: Downloads from main site redirects to 'get.html' and
- ;; returns HTTP 200, leading Guix to download that instead.
- ;; Try official mirror first. See:
- ;; https://github.com/lavv17/lftp/issues/299 and
- ;; https://lftp.tech/get.html (mirror list)
- (uri (list (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
- "ftp/lftp/lftp-" version ".tar.xz")
- (string-append "https://lftp.tech/ftp/lftp-"
+ ;; See https://lftp.tech/get.html for mirrors.
+ (uri (list (string-append "https://lftp.tech/ftp/lftp-"
version ".tar.xz")
(string-append "https://lftp.tech/ftp/old/lftp-"
- version ".tar.xz")))
+ version ".tar.xz")
+ (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
+ "ftp/lftp/lftp-" version ".tar.xz")))
(sha256
(base32
- "0b6r1gbpazvml1hvfjm2ccsfxibrjrm3fir912j6kxxn538w8rxz"))))
+ "1n6h3y5jz1rxlx7ap46vykgm0q2rvzr7c5s5ry5l32z3lbmwbdak"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
nse ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (gnu tests rsync) #:use-module (gnu packages rsync) #:use-module (gnu tests) #:use-module (gnu system) #:use-module (gnu system file-systems) #:use-module (gnu system shadow) #:use-module (gnu system vm) #:use-module (gnu services) #:use-module (gnu services rsync) #:use-module (gnu services networking) #:use-module (guix gexp) #:use-module (guix store) #:export (%test-rsync)) (define* (run-rsync-test rsync-os #:optional (rsync-port 873)) "Run tests in %RSYNC-OS, which has rsync running and listening on PORT." (define os (marionette-operating-system rsync-os #:imported-modules '((gnu services herd) (guix combinators)))) (define vm (virtual-machine (operating-system os) (port-forwardings '()))) (define test (with-imported-modules '((gnu build marionette)) #~(begin (use-modules (srfi srfi-11) (srfi srfi-64) (gnu build marionette)) (define marionette (make-marionette (list #$vm))) (mkdir #$output) (chdir #$output) (test-begin "rsync") ;; Wait for rsync to be up and running. (test-assert "service running" (marionette-eval '(begin (use-modules (gnu services herd)) ;; Make sure the 'rsync' command is found. (setenv "PATH" "/run/current-system/profile/bin") (start-service 'rsync)) marionette)) ;; Make sure the PID file is created. (test-assert "PID file" (marionette-eval '(file-exists? "/var/run/rsyncd/rsyncd.pid") marionette)) (test-assert "Test file copied to share" (marionette-eval '(begin (call-with-output-file "/tmp/input" (lambda (port) (display "test-file-contents\n" port))) (zero? (system* "rsync" "/tmp/input" (string-append "rsync://localhost:" (number->string #$rsync-port) "/files/input")))) marionette)) (test-equal "Test file correctly received from share" "test-file-contents" (marionette-eval '(begin (use-modules (ice-9 rdelim)) (zero? (system* "rsync" (string-append "rsync://localhost:" (number->string #$rsync-port) "/files/input") "/tmp/output")) (call-with-input-file "/tmp/output" (lambda (port) (read-line port)))) marionette)) (test-end) (exit (= (test-runner-fail-count (test-runner-current)) 0))))) (gexp->derivation "rsync-test" test)) (define* %rsync-os ;; Return operating system under test. (let ((base-os (simple-operating-system (service dhcp-client-service-type) (service rsync-service-type)))) (operating-system (inherit base-os) (packages (cons* rsync (operating-system-packages base-os)))))) (define %test-rsync (system-test (name "rsync") (description "Connect to a running RSYNC server.") (value (run-rsync-test %rsync-os))))