aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 631b7e2bf0..0c0a1d1765 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7257,8 +7257,7 @@ literal of the form 1.0v to conversion functions currently in scope.")
(arguments `(#:tests? #f)) ; No tests
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_optional")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-optional))))
+ (properties `((upstream-name . "ppx_optional")))
(home-page "https://github.com/janestreet/ppx_optional")
(synopsis "Pattern matching on flat options")
(description
@@ -7266,17 +7265,6 @@ literal of the form 1.0v to conversion functions currently in scope.")
else expression.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-optional
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-optional)
- (version "0.11.0")
- (source
- (janestreet-origin
- "ppx_optional" version
- "1z8z2bga95k2vksljljfglg10vygkjd24kn1b37sk4z3nmp47x0h"))
- (properties `((upstream-name . "ppx_optional"))))))
-
(define-public ocaml-ppx-optcomp
(package
(name "ocaml-ppx-optcomp")