replace_index: { options = { arguments: true, evaluate: true, properties: true, } input: { var arguments = []; console.log(arguments[0]); (function() { console.log(arguments[1], arguments["1"], arguments["foo"]); })("bar", 42); (function(a, b) { console.log(arguments[1], arguments["1"], arguments["foo"]); })("bar", 42); (function(arguments) { console.log(arguments[1], arguments["1"], arguments["foo"]); })("bar", 42); (function() { var arguments; console.log(arguments[1], arguments["1"], arguments["foo"]); })("bar", 42); } expect: { var arguments = []; console.log(arguments[0]); (function() { console.log(arguments[1], arguments[1], arguments.foo); })("bar", 42); (function(a, b) { console.log(b, b, arguments.foo); })("bar", 42); (function(arguments) { console.log(arguments[1], arguments[1], arguments.foo);
aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 79b30cecaf..3641b0fa96 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2018-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018-2021, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -354,7 +354,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(name "libcmis")
;; Note: Use an unreleased version because libreoffice requires it and
;; is the only user (see <https://github.com/tdf/libcmis/pull/43>).
- (version "0.6.0")
+ (version "0.6.2")
(home-page "https://github.com/tdf/libcmis")
(source
(origin
@@ -364,7 +364,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(file-name (git-file-name name version))
(sha256
(base32
- "17jx9fb7nmyp6jhz9nlmb3wcp8k03vhcv7sqql6a7jhsjnw3hq0k"))))
+ "0g0wr31gfhxcdfvr0l36zallz349rrxd2d8n03b0b5ffm10b4y0x"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool cppunit pkg-config))
@@ -380,13 +380,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
;; it once this is available.
"--without-man"
;; XXX: A configure test fails with GCC7 when including Boost headers.
- "--disable-werror"
- ;; During configure, the boost headers are found, but linking
- ;; fails without the following flag.
- (string-append "--with-boost="
- (dirname (dirname
- (search-input-directory %build-inputs
- "include/boost")))))
+ "--disable-werror")
#:phases
#~(modify-phases %standard-phases
(replace 'bootstrap
(a) { console.log(arguments[0], a); arguments[0]++; console.log(arguments[0], a); } f(0); } expect: { "use strict"; function f(a) { console.log(arguments[0], a); arguments[0]++; console.log(arguments[0], a); } f(0); } expect_stdout: [ "0 0", "1 0", ] } issue_3273_global_strict_reduce_vars: { options = { arguments: true, reduce_vars: true, } input: { "use strict"; function f(a) { console.log(arguments[0], a); arguments[0]++; console.log(arguments[0], a); } f(0); } expect: { "use strict"; function f(a) { console.log(arguments[0], a); arguments[0]++; console.log(arguments[0], a); } f(0); } expect_stdout: [ "0 0", "1 0", ] } issue_3273_keep_fargs_false: { options = { arguments: true, keep_fargs: false, reduce_vars: true, } input: { (function() { "use strict"; arguments[0]++; console.log(arguments[0]); })(0); } expect: { (function(argument_0) { "use strict"; argument_0++; console.log(argument_0); })(0); } expect_stdout: "1" } issue_3273_keep_fargs_strict: { options = { arguments: true, keep_fargs: "strict", reduce_vars: true, } input: { (function() { "use strict"; arguments[0]++; console.log(arguments[0]); })(0); } expect: { (function(argument_0) { "use strict"; argument_0++; console.log(argument_0); })(0); } expect_stdout: "1" } issue_3282_1: { options = { arguments: true, reduce_funcs: true, reduce_vars: true, keep_fargs: false, unused: true, } input: { (function(t) { return function() { t(); }; })(function() { 'use strict'; function e() { return arguments[0]; } e(); e(); })(); } expect: { (function() { return function() { (function() { "use strict"; function e() { return arguments[0]; } e(); e(); })(); }; })()(); } expect_stdout: true } issue_3282_1_passes: { options = { arguments: true, passes: 2, reduce_funcs: true, reduce_vars: true, keep_fargs: false, unused: true, } input: { (function(t) { return function() { t(); }; })(function() { 'use strict'; function e() { return arguments[0]; } e(); e(); })(); } expect: { (function() { return function() { (function() { "use strict"; function e(argument_0) { return argument_0; } e(); e(); })(); }; })()(); } expect_stdout: true } issue_3282_2: { options = { arguments: true, reduce_vars: true, keep_fargs: false, unused: true, } input: { (function(f) { f(); })(function() { return (function(t) { return function() { t(); }; })(function() { 'use strict'; function e() { return arguments[0]; } e(); e(); })(); }); } expect: { (function() { (function() { return function(t) { return function() { t(); }; }(function() { "use strict"; function e() { return arguments[0]; } e(); e(); })(); })(); })(); } expect_stdout: true } issue_3282_2_passes: { options = { arguments: true, passes: 2, reduce_vars: true, keep_fargs: false, unused: true, } input: { (function(f) { f(); })(function() { return (function(t) { return function() { t(); }; })(function() { 'use strict'; function e() { return arguments[0]; } e(); e(); })(); }); } expect: { (function() { (function() { return function(t) { return function() { t(); }; }(function() { "use strict"; function e(argument_0) { return argument_0; } e(); e(); })(); })(); })(); } expect_stdout: true } issue_3420_1: { options = { arguments: true, keep_fargs: "strict", } input: { console.log(function() { return function() { return arguments[0]; }; }().length); } expect: { console.log(function() { return function() { return arguments[0]; }; }().length); } expect_stdout: "0" } issue_3420_2: { options = { arguments: true, keep_fargs: "strict", } input: { var foo = function() { delete arguments[0]; }; foo(); } expect: { var foo = function() { delete arguments[0]; }; foo(); } expect_stdout: true } issue_3420_3: { options = { arguments: true, keep_fargs: "strict", } input: { "use strict"; var foo = function() { delete arguments[0]; }; foo(); } expect: { "use strict"; var foo = function() { delete arguments[0]; }; foo(); } expect_stdout: true } issue_3420_4: { options = { arguments: true, keep_fargs: "strict", } input: { !function() { console.log(arguments[0]); delete arguments[0]; console.log(arguments[0]); }(42); } expect: { !function(argument_0) { console.log(argument_0); delete arguments[0]; console.log(arguments[0]); }(42); } expect_stdout: [ "42", "undefined", ] } issue_3420_5: { options = { arguments: true, keep_fargs: "strict", } input: { "use strict"; !function() { console.log(arguments[0]); delete arguments[0]; console.log(arguments[0]); }(42); } expect: { "use strict"; !function(argument_0) { console.log(argument_0); delete arguments[0]; console.log(arguments[0]); }(42); } expect_stdout: [ "42", "undefined", ] } issue_3420_6: { options = { arguments: true, keep_fargs: "strict", } input: { console.log(function() { return delete arguments[0]; }()); } expect: { console.log(function() { return delete arguments[0]; }()); } expect_stdout: "true" } issue_3420_7: { options = { arguments: true, keep_fargs: "strict", } input: { "use strict"; console.log(function() { return delete arguments[0]; }()); } expect: { "use strict"; console.log(function() { return delete arguments[0]; }()); } expect_stdout: "true" }