aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d18c256d62..a3b9799209 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3266,9 +3266,8 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
(setenv "DISPLAY" ":1"))))))
(inputs
(append
- ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
- ;; dependency on other platforms (FIXME).
- (if (target-x86-64?)
+ ;; GJS depends on Rust so remove the GJS dependency on other platforms.
+ (if (supported-package? gjs)
(list gjs)
'())
(list gtk+ libxml2)))