aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5010377fc8..584e3cf35e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6922,28 +6922,11 @@ many values).")
(build-system dune-build-system)
(arguments `(#:tests? #f)); no tests
(propagated-inputs (list ocaml-base))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-typerep))))
(home-page "https://github.com/janestreet/typerep")
(synopsis "Typerep is a library for runtime types")
(description "Typerep is a library for runtime types.")
(license license:expat)))
-(define-public ocaml4.07-typerep
- (package-with-ocaml4.07
- (package
- (inherit ocaml-typerep)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/typerep-v" version ".tar.gz"))
- (sha256
- (base32
- "1zi7hy0prpgzqhr4lkacr04wvlvbp21jfbdfvffhrm6cd400rb5v"))))
- (properties '())
- (license license:asl2.0))))
-
(define-public ocaml-ppx-sexp-value
(package
(name "ocaml-ppx-sexp-value")