aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 295007319d..0a8c3e9452 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4441,12 +4441,17 @@ fish. The whole game is accompanied by quiet, comforting music.")
("python-pyyaml" ,python-pyyaml)
("pkg-config" ,pkg-config)))
(arguments
- '(#:make-flags
+ `(#:make-flags
(let* ((sqlite (assoc-ref %build-inputs "sqlite"))
(out (assoc-ref %outputs "out")))
(list (string-append "SQLITE_INCLUDE_DIR=" sqlite "/include")
(string-append "prefix=" out)
"SAVEDIR=~/.crawl"
+ ;; Don't compile with SSE on systems which don't use it
+ ,@(match (%current-system)
+ ((or "i686-linux" "x86_64-linux")
+ '())
+ (_ '("NOSSE=TRUE")))
;; don't build any bundled dependencies
"BUILD_LUA="
"BUILD_SQLITE="
@@ -4454,11 +4459,6 @@ fish. The whole game is accompanied by quiet, comforting music.")
"-Csource"))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-flags
- (lambda _
- (substitute* "source/Makefile"
- (("-mfpmath=sse -msse2") ""))
- #t))
(add-after 'unpack 'find-SDL-image
(lambda _
(substitute* "source/windowmanager-sdl.cc"