aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 778a592dc6..1b88d3813b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -61,6 +61,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
@@ -974,9 +975,13 @@ usable with any list--including files, command history, processes and more.")
(string-append out "/bin"))))))
(add-after 'copy-binaries 'wrap-programs
(lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (ncurses (assoc-ref inputs "ncurses")))
- (wrap-program (string-append out "/bin/fzf-tmux")
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (findutils (assoc-ref inputs "findutils"))
+ (ncurses (assoc-ref inputs "ncurses")))
+ (wrap-program (string-append bin "/fzf")
+ `("PATH" ":" prefix (,(string-append findutils "/bin"))))
+ (wrap-program (string-append bin "/fzf-tmux")
`("PATH" ":" prefix (,(string-append ncurses "/bin")))))))
(add-after 'install 'install-completions
(lambda* (#:key outputs #:allow-other-keys)
@@ -997,6 +1002,7 @@ usable with any list--including files, command history, processes and more.")
(string-append zsh-completion "/_fzf"))))))))))
(inputs
`(,@(package-inputs go-github-com-junegunn-fzf)
+ ("findutils" ,findutils)
("ncurses" ,ncurses)))))
(define-public go-github.com-howeyc-gopass
er/newt?id=7cbd95a9f662bf52a00dde2ea0123ed0dc640214'>installer: Add error page when running external commands....Josselin Poiret 2022-02-02installer: Use named prompt to abort or break installer steps....Josselin Poiret 2022-02-02installer: Replace run-command by invoke in newt/page.scm....Josselin Poiret 2022-02-02installer: Fix run-file-textbox-page when edit-button is #f....Josselin Poiret 2022-02-02installer: Use new installer-log-line everywhere....Josselin Poiret 2022-02-02installer: Add crash dump upload support....Mathieu Othacehe 2022-01-14installer: Check if ci.guix.gnu.org can be reached....Mathieu Othacehe 2022-01-14installer: Ignore small devices....Mathieu Othacehe 2021-12-28installer: Recommend 'ntp-service-type' for non-graphical systems....Leo Famulari 2021-12-28installer: Offer the CUPS printing service on a dedicated page....Leo Famulari 2021-10-21installer: Reorder file system type listbox....Tobias Geerinckx-Rice 2021-09-23installer: Support XFS....Tobias Geerinckx-Rice