aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7989b2d767..c8db6ae479 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2766,7 +2766,8 @@ quoting, commenting, and escaping.")
;; XXX: Check if the most of the tests may be enabled:
;; src/github.com/fxamacker/cbor/v2/decode_test.go:328:9: cannot convert
;; 1000000000000 (untyped int constant) to type uint
- #:tests? (target-64bit?)
+ #:tests? (and (target-64bit?)
+ (not (%current-target-system)))
#:import-path "github.com/fxamacker/cbor/v2"))
(propagated-inputs
(list go-github-com-x448-float16))