aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c46627a901..94a38a67c0 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -125,9 +125,11 @@ command-line arguments, multiple languages, and so on.")
(patches (search-patches "grep-timing-sensitive-test.patch"))))
(build-system gnu-build-system)
(native-inputs (list perl)) ;some of the tests require it
- (inputs (list pcre))
+ (inputs (list pcre2))
(arguments
- `(#:phases
+ `(#:configure-flags
+ (list "--enable-perl-regexp")
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'fix-egrep-and-fgrep
;; Patch 'egrep' and 'fgrep' to execute 'grep' via its