aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0178ca3970..587e23483c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4704,6 +4704,43 @@ of SRFI-64's @code{test-*} forms as well as some extra facilities to aid with
writing tests.")
(license license:gpl3+)))
+(define-public guile-de-paul-records
+ (package
+ (name "guile-de-paul-records")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.koszko.org/de-paul-records")
+ (commit "dbb2a98e2a63a34ffe1e416835d9e6e7f137a214")))
+ (sha256
+ (base32
+ "0m7pm5k21zb64lcmjjrdxn4c9ca74mss3kxivhnfpz17ilj5xky9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake guile-3.0 pkg-config lawrence-boilerplate))
+ (inputs
+ (list guile-3.0 guile-myra-test-utils))
+ (home-page "https://git.koszko.org/de-paul-records/about")
+ (synopsis "Pure records API for GNU Guile")
+ (description "This library builds upon @code{(srfi srfi-9 gnu)}. It
+features:
+
+@itemize
+@item automatic deriving of getter names from field names;
+@item automatic generation of record constructor macros;
+@item support for default field values;
+@item support for programmer-supplied record finalizer procedures;
+@item syntax for creation of a record object based on an existing one;
+@item optional automatic export of generated getters and other variables;
+@item amended variants of @code{(ice-9 match)} forms with (unhygienic) record
+matcher that allows fields to be matched by name.
+@end itemize
+
+This library is inspired by the Guix records API but follows purely functional
+approach.")
+ (license license:cc0)))
+
(define-public guile-semver
(package
(name "guile-semver")