aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shellutils.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 070613afe1..cbeaa05b3d 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -188,33 +188,32 @@ in Zsh intelligently.")
(build-system gnu-build-system)
(native-inputs
(list ruby
- ruby-byebug
ruby-pry
ruby-rspec
ruby-rspec-wait
tmux
zsh))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- ;; Failing tests since tmux-3.2a
- (delete-file "spec/options/buffer_max_size_spec.rb")))
- (delete 'configure)
- (replace 'check ; Tests use ruby's bundler; instead execute rspec directly.
- (lambda _
- (setenv "TMUX_TMPDIR" (getenv "TMPDIR"))
- (setenv "SHELL" (which "zsh"))
- (invoke "rspec")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (zsh-plugins
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ ;; Failing tests since tmux-3.2a
+ (delete-file "spec/options/buffer_max_size_spec.rb")))
+ (delete 'configure)
+ (replace 'check ; Tests use ruby's bundler; instead execute rspec directly.
+ (lambda _
+ (setenv "TMUX_TMPDIR" (getenv "TMPDIR"))
+ (setenv "SHELL" (which "zsh"))
+ (invoke "rspec")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (zsh-plugins
(string-append out "/share/zsh/plugins/zsh-autosuggestions")))
- (invoke "make" "all")
- (install-file "zsh-autosuggestions.zsh" zsh-plugins)
- #t))))))
+ (invoke "make" "all")
+ (install-file "zsh-autosuggestions.zsh" zsh-plugins)))))))
(home-page "https://github.com/zsh-users/zsh-autosuggestions")
(synopsis "Fish-like autosuggestions for zsh")
(description
ve-inputs]: Remove python & add pkg-config. [inputs]: Add argon2 & json-c. (cryptsetup-static): Disable new binaries. Keep using libgcrypt. Disable blkid support. [inputs]: Add json-c. Tobias Geerinckx-Rice 2019-10-05gnu: cryptsetup-static: Don't build veritysetup....* gnu/packages/cryptsetup.scm (cryptsetup-static)[arguments]: Pass ‘--disable-veritysetup’ #:configure-flag. Adjust ‘remove-cruft’ phase. Tobias Geerinckx-Rice 2019-10-05gnu: cryptsetup: Don't use NAME in source URI....* gnu/packages/cryptsetup.scm (cryptsetup)[source]: Hard-code NAME. Tobias Geerinckx-Rice