aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ea153978f..02ef243e18 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6277,6 +6277,18 @@ data serialization format.")
(list #:import-path "google.golang.org/protobuf"
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX Failing on i686-linux:
+ ;; panic: unaligned 64-bit atomic operation
+ (("TestDynamicTypesExtensionNotFound")
+ "OffTestDynamicTypesExtensionNotFound")
+ (("TestDynamicTypesFilesChangeAfterCreation")
+ "OffTestDynamicTypesFilesChangeAfterCreation")
+ (("TestDynamicTypesFindExtensionByNameOrNumber")
+ "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
;; XXX: Workaround for go-build-system's lack of Go modules
;; support.
(delete 'build)