aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1ff6cb9892..65799ef463 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -420,6 +420,30 @@ made to get a better separation of core libraries and applications.
@url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
(license license:gpl2+)))
+(define-public ccfits
+ (package
+ (name "ccfits")
+ (version "2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/"
+ "CCfits-" version ".tar.gz"))
+ (sha256
+ (base32 "04l6na8vr5xadz3rbx62as79x1ch4994vbb625kx0dz5czdkkd1b"))))
+ (build-system cmake-build-system)
+ (inputs (list cfitsio))
+ (home-page "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/")
+ (synopsis "C++ interface to the CFITSIO")
+ (description
+ "CCfits is an object oriented interface to the cfitsio library. It is
+designed to make the capabilities of cfitsio available to programmers working in
+C++. It is written in ANSI C++ and implemented using the C++ Standard Library
+with namespaces, exception handling, and member template functions.")
+ (license (license:non-copyleft "file://License.txt"
+ "See License.txt in the distribution."))))
+
(define-public cfitsio
(package
(name "cfitsio")