aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index febd1e80ce..3f90febc43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1529,15 +1529,19 @@ Style Sheets (CSS) rule sets in Ruby.")
"0mbxzw7r7hv43db9422flc24ib9d8bdy1nasbni2h998jc5a5lb6"))))
(build-system ruby-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'do-not-use-bundler
- (lambda _
- (substitute* "spec/spec_helper.rb"
- ((".*[Bb]undler.*") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "rspec" "-Ilib" "-rprawn-svg")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundler
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*[Bb]undler.*") ""))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; This test fails due to the recent rspec 3.12 used
+ ;; (see: https://github.com/mogest/prawn-svg/issues/151).
+ (delete-file "spec/prawn/svg/interface_spec.rb")
+ (invoke "rspec" "-Ilib" "-rprawn-svg")))))))
(native-inputs (list ruby-rspec))
(propagated-inputs (list ruby-css-parser ruby-prawn))
(synopsis "SVG renderer for the Prawn PDF library")