aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 293b873fc2..c9f7af0a8e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2450,7 +2450,7 @@ Linux-based operating systems.")
(define-public libcap
(package
(inherit libcap-2.31)
- (version "2.34")
+ (version "2.44")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2458,7 +2458,19 @@ Linux-based operating systems.")
"libcap2/libcap-" version ".tar.xz"))
(sha256
(base32
- "048n1gy2p48vl9hkrr9wymfxxcpwj2aslz2bv79nhl4m2lhd9kdf"))))))
+ "1qf80lifygbnxwvqjf8jz5j24n6fqqx4ixnkbf76xs2vrmcq664j"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments libcap-2.31)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'configure
+ (lambda _
+ ;; Add $libdir to the RUNPATH of executables.
+ (substitute* "Make.Rules"
+ (("LDFLAGS \\?= #-g")
+ (string-append "LDFLAGS ?= -Wl,-rpath="
+ %output "/lib")))
+ #t))))))))
(define-deprecated libcap/next libcap)
(export libcap/next)
6acb3eefe08cac36c3b'>gnu: go-github-com-google-gofuzz: Move to (gnu packages golang-check)....* gnu/packages/golang-check.scm (go-github-com-google-gofuzz): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-jacobsa-ogletest: Move to (gnu packages golang-check)....* gnu/packages/golang-check.scm (go-github-com-jacobsa-ogletest): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-tdewolff-test: Move to (gnu packages golang-check)....* gnu/packages/golang-check.scm (go-github-com-tdewolff-test): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-gopkg-in-go-playground-assert-v1: Move to (gnu packages golang-check)....* gnu/packages/golang-check.scm (go-gopkg-in-go-playground-assert-v1): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-golangplus-testing: Move to (gnu packages golang-check)....* gnu/packages/golang.scm (go-github-com-golangplus-testing): Move from here... * gnu/packages/golang-check.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-jacobsa-oglematchers: Move to (gnu packages golang-check)....* gnu/packages/golang.scm (go-github-com-jacobsa-oglematchers): Move from here... * gnu/packages/golang-check.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-gopkg-in-check-v1: Move to (gnu packages golang-check)....* gnu/packages/golang.scm (go-gopkg-in-check-v1): Move from here... * gnu/packages/golang-check.scm (go-gopkg-in-check-v1): ... to here. * gnu/packages/bioinformatics.scm: Add (gnu-packages golang-check) to use-module. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-stretchr-testify: Remove labels....* gnu/packages/golang-check.scm (go-github-com-stretchr-testify): Remove input lables. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Ibe9dcd7b55681cf6c5b76c44ef03de2e2f02bcd9 Sharlatan Hellseher 2023-10-22gnu: go-github-com-jacobsa-oglemock: Move to (gnu packages golang-check)...* gnu/packages/golang.scm (go-github-com-jacobsa-oglemock): Move from here... * gnu/packages/golang-check.scm: ... to here. * gnu/packages/file-systems.scm: Add use-module (gnu-packages golang-check). Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check)....* gnu/packages/golang.scm (go-github-com-stretchr-testify): Move from here... * gnu/packages/golang-check.scm: ...to here. * gnu/packages/databases.scm: Add (gnu packages golang-check) module. * gnu/packages/education.scm: As above... * gnu/packages/ipfs.scm: As above... * gnu/packages/irc.scm: As above... * gnu/packages/mail.scm: As above... * gnu/packages/textutils.scm: As above... * gnu/packages/version-control.scm: As above... Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher 2023-10-22gnu: Add (gnu packages golang-check) module....* gnu/packages/golang-check.scm: New file. * gnu/local.mk: Add to gnu/packages/golang-check.scm scope. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Sharlatan Hellseher