aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5d873e0884..b46286c690 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -423,6 +423,28 @@ Interface} specification.")
(license license:asl2.0)
(home-page "https://modwsgi.readthedocs.io/")))
+(define-public ablorb
+ (package
+ (name "ablorb")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/lilyp/ablorb")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i705p2gw5aryj0myfj3rmsrmj3ilqdn5w7xd5dwjkyi80rc20kj"))))
+ (build-system meson-build-system)
+ (inputs (list glib gconf gnome-vfs libxml2))
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.gnome.org/lilyp/ablorb")
+ (synopsis "Replace asset links with data URIs")
+ (description "Ablorb takes an XML file and resolves relative links,
+replacing them with data URIs.")
+ (license license:gpl3+)))
+
(define-public monolith
(package
(name "monolith")