aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 2ac72972a2..2dcaa5dd8d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -239,14 +239,14 @@ components of the LXQt desktop environment.")
(define-public libsysstat
(package
(name "libsysstat")
- (version "0.4.1")
+ (version "0.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0ngz8v3bixsdg96d5ipcyxd6nsrg52974xdxy9rnimahlv1yaxn3"))))
+ (base32 "0rz9w49khra9kl91kfnd3wxkldy1fqf6755mvlgbsqxb1yv8597w"))))
(build-system cmake-build-system)
(arguments '(#:tests? #f)) ; no tests
(inputs
> 2016-06-20tests: Add system installation test.Ludovic Courtès * gnu/tests.scm (define-os-with-source): New macro. * gnu/tests/install.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * build-aux/run-system-tests.scm (%system-tests): Likewise. 2016-05-04build: Add 'run-system-tests.scm'.Ludovic Courtès This file was meant to be added as part of commit e9f693d06f94bd96488c3910dba6504f94a6b6f9. * build-aux/run-system-tests.scm: New file. * Makefile.am (EXTRA_DIST): Add it. 2016-05-04build: Preserve stderr for shell tests.Ludovic Courtès Fixes a regression introduced in a9edb211e733b8b34e67ec3b4450567e9376986f where the .log files of the .sh tests would not contain stderr. * build-aux/test-env.in: Redirect stderr only when --quiet-stderr is passed. * Makefile.am (SCM_LOG_DRIVER): Add --quiet-stderr. 2016-04-27build: 'make assert-binaries-available' shows the list of systems.Ludovic Courtès * build-aux/check-available-binaries.scm: Display %HYDRA-SUPPORTED-SYSTEMS. 2016-04-15build: Move environment '.in' scripts to 'build-aux' directory.Mathieu Lirzin * pre-inst-env.in: Move to ... * build-aux/pre-inst-env.in: ... here. * test-env.in: Move to ... * build-aux/test-env.in: ... here. * configure.ac (AC_CONFIG_FILES): Adapt to this. Keep the generated scripts in their current location which is $(top_builddir). 2016-04-13hydra: Add 'hydra-jobs.scm' target to compute the Hydra jobs.Ludovic Courtès * build-aux/hydra/evaluate.scm: New file. * Makefile.am (EXTRA_DIST): Add it. 2016-04-13hydra: Really completely disable grafting.Ludovic Courtès This is a followup to 49c4fd2a. * build-aux/hydra/gnu-system.scm (package->alist): Parameterize %graft?. (qemu-jobs)[->job]: Likewise. (tarball-jobs)[->job]: Likewise. 2016-04-03build: Add a Guile custom test driver using SRFI-64.Mathieu Lirzin Before that '.log' files for scheme tests were fragmented and not included in test-suite.log. This unifies the semantics of SRFI-64 API with Automake test suite. * build-aux/test-driver.scm: New file. * Makefile.am (SCM_LOG_DRIVER, AM_SCM_LOG_DRIVER_FLAGS): New variables. (SCM_LOG_COMPILER, AM_SCM_LOG_FLAGS): Delete variables. (AM_TESTS_ENVIRONMENT): Set GUILE_AUTO_COMPILE to 0. * test-env.in: Silence guix-daemon. * doc/guix.texi (Running the Test Suite): Describe how to display the detailed results. Bug reports require only 'test-suite.log' file. * tests/base32.scm, tests/build-utils.scm, tests/builders.scm, tests/challenge.scm, tests/cpan.scm, tests/cpio.scm, tests/cran.scm, tests/cve.scm, tests/derivations.scm, tests/elpa.scm, tests/file-systems.scm, tests/gem.scm, tests/gexp.scm, tests/gnu-maintenance.scm, tests/grafts.scm, tests/graph.scm, tests/gremlin.scm, tests/hackage.scm, tests/hash.scm, tests/import-utils.scm, tests/lint.scm, tests/monads.scm, tests/nar.scm, tests/packages.scm, tests/pk-crypto.scm, tests/pki.scm, tests/profiles.scm, tests/publish.scm, tests/pypi.scm, tests/records.scm, tests/scripts-build.scm, tests/scripts.scm, tests/services.scm, tests/sets.scm, tests/size.scm, tests/snix.scm, tests/store.scm, tests/substitute.scm, tests/syscalls.scm, tests/system.scm, tests/ui.scm, tests/union.scm, tests/upstream.scm, tests/utils.scm: Don't exit at the end of test groups. * tests/containers.scm: Likewise. Use 'test-skip' instead of exiting with error code 77. 2016-03-24doc: We now need 1 GiB for the installation USB image.Ludovic Courtès * doc/guix.texi (Building the Installation Image): Change image size to 1G. * build-aux/hydra/gnu-system.scm (qemu-jobs): Likewise. 2016-03-03build: Use (guix grafts) as needed.Ludovic Courtès This is a followup to 7adf9b8. * build-aux/check-final-inputs-self-contained.scm: Use (guix grafts). * build-aux/check-available-binaries.scm: Likewise. 2016-03-03hydra: Completely disable grafting.Ludovic Courtès * build-aux/hydra/gnu-system.scm (hydra-jobs): Parameterize '%graft?'. Build package replacements when they are available. 2016-03-03hydra: Improve readability.Ludovic Courtès * build-aux/hydra/gnu-system.scm (hydra-jobs): Use 'filter-map' instead of directly 'fold-packages'. 2016-02-01build: Remove semicolons from Guile warnings.Ludovic Courtès * build-aux/compile-all.scm (compile-file*): Clear *CURRENT-WARNING-PREFIX*. 2016-02-01build: Really enable Guile warnings.Ludovic Courtès * build-aux/compile-all.scm (compile-options): Rename to... (warnings): ... this. Add 'unsupported-warning'. (compile-file*): Pass '(#:warnings ...) as #:opts. 2016-01-29Rename 'dmd' to 'shepherd' in comments and strings.Alex Kost * build-aux/hydra/demo-os.scm (operating-system)[issue]: Point to shepherd instead of dmd. * ROADMAP: Likewise. * gnu/build/install.scm (directives): Adjust comment. 2016-01-28build: Add 'DL' silent rule.Mathieu Lirzin * Makefile.am (AM_V_DL, AM_V_DL_, AM_V_DL_0): New variables. * gnu-system.am (gnu/packages/bootstrap/x86_64-linux/guile-2.0.9.tar.xz) (gnu/packages/bootstrap/i686-linux/guile-2.0.9.tar.xz) (gnu/packages/bootstrap/armhf-linux/guile-2.0.11.tar.xz) (gnu/packages/bootstrap/mips64el-linux/guile-2.0.9.tar.xz): Use $(AM_V_DL). * build-aux/download.scm: Print a line break between target and origin. 2016-01-19hydra: Honor the 'max-silent-time' package property.Ludovic Courtès Suggested by Mark H Weaver <mhw@netris.org>. * build-aux/hydra/gnu-system.scm (package->alist): Add 'max-silent-time' pair. 2016-01-18build: Speed up .go compilation.Taylan Ulrich Bayırlı/Kammer * build-aux/compile-all.scm: New file. * Makefile.am (EXTRA_DIST): Add it. (%.go, make-go): New rules. 2016-01-13hydra: Add missing phase and inputs for 'make dist' job.Ludovic Courtès * build-aux/hydra/guix.scm (tarball-package): Inherit from 'guix-devel' rather than 'guix'. Pass #:phases to 'dist-package'. 2015-10-14hydra: Add Graphviz and help2man as inputs to the Guix job set.Ludovic Courtès * build-aux/hydra/guix.scm (tarball-package): Add GRAPHVIZ and HELP2MAN to 'native-inputs' of GUIX.