aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust-apps.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index ad9afb1923..e6cce4d372 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3025,7 +3025,22 @@ files.")
`(#:install-source? #f
#:cargo-inputs
(("rust-exitcode" ,rust-exitcode-1)
- ("rust-swayipc" ,rust-swayipc-2))))
+ ("rust-swayipc" ,rust-swayipc-2))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (string-append out "/etc/bash_completion.d/"))
+ (fish (string-append out "/share/fish/vendor_completions.d/"))
+ (zsh (string-append out "/share/zsh/site-functions/")))
+ (mkdir-p bash)
+ (mkdir-p zsh)
+ (copy-file "completions/swayhide.bash"
+ (string-append bash "swayhide"))
+ (copy-file "completions/swayhide.zsh"
+ (string-append zsh "_swayhide"))
+ (install-file "completions/swayhide.fish" fish)))))))
(home-page "https://github.com/NomisIV/swayhide/")
(synopsis "Swallow windows on swaywm")
(description "swayhide hides the currently active terminal (by moving it