aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 45a5284c93..cf1af954b8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8766,6 +8766,22 @@ get an precise reference of when the executable was built.")))
(synopsis "Communicate with ocaml dune using rpc")
(description "Library to connect and control a running dune instance.")))
+(define-public ocamlc-loc
+ (package
+ (inherit dune-ordering)
+ (name "ocamlc-loc")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "ocamlc-loc"
+ ;; Tests have a cyclic dependency on stdune
+ #:tests? #f))
+ (propagated-inputs (list dune-dyn ocaml-odoc))
+ (synopsis "Parse ocaml compiler output into structured form")
+ (description
+ "This library parses ocaml complier output and returns it as ocaml values.
+This library offers no backwards compatibility guarantees.")))
+
+
(define-public ocaml-either
(package
(name "ocaml-either")