aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index e86341fef9..e6499987e4 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -410,6 +410,34 @@ various URI schemes and MIME types. It is an implementation of the thumbnail
management D-Bus specification.")
(license gpl2+)))
+(define-public libxfce4windowing
+ (package
+ (name "libxfce4windowing")
+ (version "4.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/xfce/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0s4zjf7bwzski7zsmb7i5frd4xr8w7ng8gn8285b0vv0g4frpwjn"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config xfce4-dev-tools))
+ (propagated-inputs (list gtk+)) ; required by libxfce4windowing-0.pc
+ (inputs (list libdisplay-info
+ libwnck
+ libxrandr
+ wayland
+ wayland-protocols))
+ (home-page "https://www.xfce.org/")
+ (synopsis "Windowing concept abstraction library for X11 and Wayland")
+ (description
+ "Libxfce4windowing is an abstraction library that attempts to present
+windowing concepts (screens, toplevel windows, workspaces, etc.) in a
+windowing-system-independent manner.")
+ (license lgpl2.1+)))
+
(define-public xfce4-panel
(package
(name "xfce4-panel")