aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm41
-rw-r--r--gnu/packages/golang-xyz.scm40
2 files changed, 41 insertions, 40 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b36a618e56..d4b4c4043f 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
@@ -2835,6 +2836,46 @@ via REST APIs.")
(description "@code{bluemonday} is a HTML sanitizer implemented in Go.")
(license license:bsd-3)))
+(define-public go-github-com-miekg-dns
+ (package
+ (name "go-github-com-miekg-dns")
+ (version "1.1.62")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miekg/dns")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wdsacp4ay6ji72vnszq6ksn5n060z2hv94wgjsn0pr7gpa3nk6c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/miekg/dns"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Unable to run test server.
+ (("TestIsPacketConn") "OffTestIsPacketConn"))))))))
+ (propagated-inputs
+ (list go-golang-org-x-tools
+ go-golang-org-x-sys
+ go-golang-org-x-sync
+ go-golang-org-x-net))
+ (home-page "https://github.com/miekg/dns")
+ (synopsis "Domain Name Service library in Go")
+ (description
+ "This package provides a fully featured interface to the @acronym{DNS,
+Domain Name System}. Both server and client side programming is supported.
+The package allows complete control over what is sent out to the @acronym{DNS,
+Domain Name Service}. The API follows the less-is-more principle, by
+presenting a small interface.")
+ (license license:bsd-3)))
+
(define-public go-github-com-multiformats-go-multiaddr
(package
(name "go-github-com-multiformats-go-multiaddr")
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0be25d8bc9..09e45175a6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4405,46 +4405,6 @@ language, namely support for record length-delimited message streaming.")
colored strings.")
(license license:expat))))
-(define-public go-github-com-miekg-dns
- (package
- (name "go-github-com-miekg-dns")
- (version "1.1.62")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/miekg/dns")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0wdsacp4ay6ji72vnszq6ksn5n060z2hv94wgjsn0pr7gpa3nk6c"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/miekg/dns"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; Unable to run test server.
- (("TestIsPacketConn") "OffTestIsPacketConn"))))))))
- (propagated-inputs
- (list go-golang-org-x-tools
- go-golang-org-x-sys
- go-golang-org-x-sync
- go-golang-org-x-net))
- (home-page "https://github.com/miekg/dns")
- (synopsis "Domain Name Service library in Go")
- (description
- "This package provides a fully featured interface to the @acronym{DNS,
-Domain Name System}. Both server and client side programming is supported.
-The package allows complete control over what is sent out to the @acronym{DNS,
-Domain Name Service}. The API follows the less-is-more principle, by
-presenting a small interface.")
- (license license:bsd-3)))
-
(define-public go-github-com-mitchellh-colorstring
(package
(name "go-github-com-mitchellh-colorstring")