aboutsummaryrefslogtreecommitdiff
path: root/gnu/services
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/xorg.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index 0b9803c425..e7d8922d76 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -92,6 +92,7 @@
xorg-start-command-xinit
xinitrc
xorg-server-service-type
+ startx-command-service-type
%default-slim-theme
%default-slim-theme-name
@@ -496,6 +497,38 @@ therefore it works well when executed from tty."
(program-file "startx" exp))
+(define (startx-command-profile-service config)
+ ;; XXX: profile-service-type only accepts <package> objects.
+ (package
+ (name "startx-profile-package")
+ (version "0")
+ (source (xorg-start-command-xinit config))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(begin
+ (use-modules (guix build utils))
+ (let ((bin (string-append #$output "/bin")))
+ (mkdir-p bin)
+ (symlink #$source (string-append bin "/startx"))))))
+ (home-page #f)
+ (synopsis #f)
+ (description #f)
+ (license #f)))
+
+(define startx-command-service-type
+ (service-type
+ (name 'startx-command)
+ (extensions
+ (list (service-extension profile-service-type
+ (compose list startx-command-profile-service))))
+ (default-value (xorg-configuration))
+ (description "Add @command{startx} to the system profile.")))
+
+
+
(define* (xinitrc #:key fallback-session)
"Return a system-wide xinitrc script that starts the specified X session,
which should be passed to this script as the first argument. If not, the
Jan Nieuwenhuizen 2018-12-16gnu: mes: Update to 0.19....* gnu/packages/mes.scm (mes): Update to 0.19. Jan Nieuwenhuizen 2018-10-23gnu: mescc-tools: Update to 0.5.2-0.bb062b0d....* gnu/packages/mes.scm (mescc-tools): Update to 0.5.2-0.bb062b0d. mescc * gnu/packages/commencement.scm (mescc-tools-boot): Stay at 0.5.2 Jan Nieuwenhuizen 2018-10-21bootstrap: Add %mes-stripped, %mes-bootstrap-tarball....* gnu/packages/make-bootstrap.scm (%mes-stripped): New variable. (%mes-bootstrap-tarball): New variable. * gnu/packages/mes.scm: Oops, remove stray (gnu packages commencement) module include. Jan Nieuwenhuizen 2018-10-21gnu: mes: Update to 0.18.0-08f04f55....This update is a preparation for the %bootstrap-mes package; due to some small problems it fails to build with plain mes-0.18. mes-boot0 stays at 0.18 only to avoid another rebuild world. %bootstrap-mes brings the building and packaging the Mes bootstrap seeds from manual operation into Guix. We will bump mes and mes-boot0 to a future 0.18.1 or 0.19 and regenerate %bootstrap-mes in a nex iteration. 08f04f55 build: Oops, remove stray lib/linux/x86_64-mes/crt1. 33f37f27 build: x86_64 bootstrap build fixes and workaround. 4ae2a111 doc: Release update. 5277669b mescc: Oops, delete wrong line of assembly. 44cc97a8 admin: Release update. * gnu/packages/mes.scm (mes): Update to 0.18.0-08f04f55. * gnu/packages/commencement.scm (mes-boot0): Stay at 0.18.0. Jan Nieuwenhuizen 2018-10-07gnu: mes: Update to 0.18....* gnu/packages/patches/mes-nyacc-0.86.0.patch: Removef file. * gnu/local.mk (dist_patch_DATA): Remove entry. * gnu/packages/mes.scm (mes): Update to 0.18. Jan Nieuwenhuizen 2018-10-07gnu: mes: Update to 0.18....* gnu/packages/patches/mes-nyacc-0.86.0.patch: Removef file. * gnu/local.mk (dist_patch_DATA): Remove entry. * gnu/packages/mes.scm (mes): Update to 0.18. Jan Nieuwenhuizen