aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-vcs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index f0bfc6b5b0..922767811f 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -2311,6 +2311,32 @@ directory walking.")
This package is part of Gitoxide, a pure Rust implementation of Git.")
(license (list license:expat license:asl2.0))))
+(define-public rust-gix-discover-0.33
+ (package
+ (inherit rust-gix-discover-0.35)
+ (name "rust-gix-discover")
+ (version "0.33.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-discover" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03j52f646q05igg4bln6svjxhxiz944khinj7sx33jy3rqqjfrk7"))))
+ (arguments
+ `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+ ("rust-dunce" ,rust-dunce-1)
+ ("rust-gix-fs" ,rust-gix-fs-0.11)
+ ("rust-gix-hash" ,rust-gix-hash-0.14)
+ ("rust-gix-path" ,rust-gix-path-0.10)
+ ("rust-gix-ref" ,rust-gix-ref-0.45)
+ ("rust-gix-sec" ,rust-gix-sec-0.10)
+ ("rust-thiserror" ,rust-thiserror-1))
+ #:cargo-development-inputs (("rust-defer" ,rust-defer-0.2)
+ ("rust-is-ci" ,rust-is-ci-1)
+ ("rust-serial-test" ,rust-serial-test-3)
+ ("rust-tempfile" ,rust-tempfile-3))))))
+
(define-public rust-gix-discover-0.28
(package
(inherit rust-gix-discover-0.35)
-10-25installer: welcome: Warn when uvesafb gets used....There will be false positives: Because the Guix installer uses the kernel argument modprobe.blacklist=radeon,amdgpu and some AMD graphics actually work okay according to h-node, these users will get a false alarm. * gnu/installer/newt/welcome.scm (run-welcome-page): Warn before showing the welcome page. pelzflorian (Florian Pelz) 2022-10-20installer: Add a missing confirmation page before formatting....This is a follow-up of: <https://issues.guix.gnu.org/57232> * gnu/installer/newt/partition.scm (run-label-page): Add a confirmation page when dealing with an EFI installation. Mathieu Othacehe 2022-10-20installer: Propose the user to report a "guix system init" failure....* gnu/installer/newt/final.scm (run-install-failed-page): Add a "Report the failure" button. Mathieu Othacehe 2022-10-17installer: Factorize url-alive? in internet check....* gnu/installer/newt/network.scm (wait-service-online): Factorize url-alive? in internet check. Andrew Tropin 2022-10-17installer: Relax internet check availability criteria....Checks the availability of the mirror bordeaux.guix.gnu.org in addition to ci.guix.gnu.org. This allows to proceed the installation if the ci.guix.gnu.org is unavailable. * gnu/installer/newt/network.scm (wait-service-online): Relax internet check availability criteria. Signed-off-by: Andrew Tropin <andrew@trop.in> aleksandr barakin 2022-10-17guix: Fix typos....These typos were found and reported through weblate. * gnu/packages/audio.scm (wildmidi)[description]: Fix typo. * gnu/packages/games.scm (cgoban)[description]: Fix typo. * gnu/services/version-control.scm (gitolite-service-type)[description]: Fix typo. * gnu/installer/newt/substitutes.scm (run-substitutes-page): Remove full stop at end of title. * gnu/machine/ssh.scm (machine-ssh-configuration-system): Move punctuation outside of quotes. * guix/scripts/home.scm (process-action): Remove trailing space before newline. * guix/scripts/system.scm (show-help): Fix typo. * guix/scripts/environment.scm (with-store/maybe): Fix typo. Julien Lepiller 2022-10-13installer: partition: Add a confirmation page before formatting....Fixes: <https://issues.guix.gnu.org/57232>. * gnu/installer/newt/partition.scm (run-label-confirmation-page): New procedure. (run-label-page): Call the above procedure before proceeding. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Mathieu Othacehe 2022-09-22installer: Exit console-services page with abort-to-prompt....* gnu/installer/newt/services.scm (run-console-services-cbt-page): Do it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Josselin Poiret 2022-09-22installer: Return partitions with crypt password as step result....* gnu/installer/newt/partition.scm (run-partitioning-page): Do it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Josselin Poiret 2022-09-22installer: Move <secret> to utils and use it for crypt passwords....* gnu/installer/user.scm (<secret>, secret?, make-secret, secret-content): Move to utils.scm. * gnu/installer/utils.scm (<secret>, secret?, make-secret, secret-content): Moved from user.scm. * gnu/installer/newt/partition.scm (prompt-luks-passwords): Make password a <secret>. * gnu/installer/parted.scm (luks-format-and-open): Unwrap secret. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Josselin Poiret