aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 2 insertions, 25 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0686b0128..25ad86f204 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -371,6 +371,7 @@ data types.")
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
+ "python-3-arm-alignment.patch"
"python-3-fix-tests.patch"
"python-3.8-fix-tests.patch"
"python-3-deterministic-build-info.patch"
@@ -473,33 +474,9 @@ data types.")
,file)))
(find-files out "\\.py$")))
(list '() '("-O") '("-OO")))
- #t)))
- ;; XXX: Apply patch on ARM platforms only to avoid a full rebuild.
- ;; Remove this phase in the next rebuild cycle.
- ,@(let ((system (or (%current-target-system)
- (%current-system))))
- (if (any (cute string-prefix? <> system)
- '("arm" "aarch64"))
- '((add-after 'unpack 'apply-alignment-patch
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (invoke "patch" "-p1" "--force" "--input"
- (assoc-ref (or native-inputs inputs)
- "arm-alignment.patch")))))
- '()))))))
+ #t)))))))
(native-inputs
`(("tzdata" ,tzdata-for-tests)
-
- ;; Disable unaligned accesses in the sha3 module on ARM as
- ;; it causes a test failure when building 32-bit Python on a
- ;; 64-bit kernel. See <https://bugs.python.org/issue36515>.
- ;; TODO: make this a regular patch in the next rebuild cycle.
- ,@(let ((system (or (%current-target-system)
- (%current-system))))
- (if (any (cute string-prefix? <> system)
- '("arm" "aarch64"))
- `(("arm-alignment.patch" ,(search-patch "python-3-arm-alignment.patch")))
- '()))
-
,@(if (%current-target-system)
`(("python3" ,this-package))
'())
cate. (guile-gi): Switch to GUILE-3.0. (guile2.2-gi): New variable. (guile3.0-gi): Deprecate. (guile-hashing): Switch to GUILE-3.0. (guile2.2-hashing): New variable. (guile3.0-hashing): Deprecate. * gnu/packages/package-management.scm (guix): Switch to GUILE-3.0. (guile2.2-guix): New variable. (guile3.0-guix): Deprecate. (gwl): Replace "guile3.0-" with "guile-". (guix-jupyter)[source]: Adjust for Guile 3.0. Switch to GUILE-3.0. * gnu/packages/ssh.scm (guile-ssh): Switch to GUILE-3.0. (guile2.2-ssh): New variable. (guile3.0-ssh): Deprecate. * gnu/packages/admin.scm (shepherd): Switch to GUILE-3.0. (guile2.2-shepherd): New variable. (guile3.0-shepherd): Deprecate. * gnu/packages/mail.scm (mailutils): Switch to GUILE-3.0. (guile2.2-mailutils): New variable. (guile3.0-mailutils): Deprecate. * gnu/packages/plotutils.scm (guile-charting): Switch to GUILE-3.0. (guile2.2-charting): New variable. (guile3.0-charting): Deprecate. * gnu/packages/version-control.scm (libgit2): Switch to GUILE-3.0. * gnu/packages/vpn.scm (vpnc-scripts): Switch to GUILE-3.0. * gnu/packages/web.scm (guix-data-service): Switch to GUILE-3.0. (hpcguix-web): Switch to GUILE-3.0. * guix/self.scm (specification->package): Refer to the "guile-" variants instead of "guile3.0-". * guix/gexp.scm (default-guile): Change to GUILE-3.0. * build-aux/build-self.scm (build): #:guile-version defaults to "3.0". * gnu/packages/commencement.scm (guile-final): Base on GUILE-3.0/FIXED. Ludovic Courtès 2020-03-10gnu: asymptote: Update to 2.64....* gnu/packages/plotutils.scm (asymptote): Update to 2.64. Nicolas Goaziou 2020-03-09gnu: plotutils: Use HTTPS home page....* gnu/packages/plotutils.scm (plotutils)[home-page]: Use HTTPS. Tobias Geerinckx-Rice 2020-01-27gnu: guile-charting: Add "guile3.0-charting" variant....* gnu/packages/plotutils.scm (guile-charting)[source]: In 'snippet', have 'configure' look for 3.0. (guile3.0-charting): New variable. Ludovic Courtès 2020-01-16gnu: asymptote: Add missing input....* gnu/packages/plotutils.scm (asymptote)[inputs]: Add missing input for GUI. Nicolas Goaziou 2020-01-16gnu: asymptote: Fix GUI....Fixes bug#39147. * gnu/packages/plotutils.scm (asymptote)[inputs]: Add missing inputs. [arguments]: Wrap GUI executable "xasy". Nicolas Goaziou 2020-01-15gnu: asymptote: Update to 2.62....* gnu/packages/plotutils.scm (asymptote): Update to 2.62. Nicolas Goaziou 2019-12-01gnu: asymptote: Update to 2.61....* gnu/packages/plotutils.scm (asymptote): Update to 2.61. Nicolas Goaziou 2019-11-01gnu: asymptote: Update to 2.59....* gnu/packages/plotutils.scm (asymptote): Update to 2.59. Nicolas Goaziou