aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/pkg-config.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index b15b646416..6292fb05e2 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -171,14 +172,14 @@ exec ~a \"$@\""
(define-public pkgconf
(package
(name "pkgconf")
- (version "1.9.3")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://distfiles.dereferenced.org/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "17b9cl2s99pzgblaj0yg49k3m0by5x78vwg4879vckymhys5bcsz"))))
+ "00a4cv1f8cxsb4jhpgxxrwrl92b1zdsirqn0gqvva7i5izpjanpa"))))
(build-system gnu-build-system)
(arguments (list #:tests? #f)) ;TODO: package kyua
(home-page "http://pkgconf.org/")
: New variable. (speed-dreams-version, speed-dreams-svn-revision): New variables. (speed-dreams-source-tarball): New procedure. (speed-dreams-base-tarball, speed-dreams-more-hq-cars-and-tracks-tarball) (speed-dreams-wip-cars-and-tracks-tarball) (speed-dreams-unmaintained-tarball): New variable. Change-Id: Id14f3556d47a80c508177940f959448520b406fc Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Maxim Cournoyer 2024-11-12gnu: torcs: Fix source file name....* gnu/packages/games.scm (torcs) [source]: Specify file-name field. [arguments]: Precise URL in comment. Change-Id: I9730e9aa75e17068b821ce211cb4591f53c47681 Maxim Cournoyer 2024-11-12gnu: Add torcs....* gnu/packages/games.scm (torcs): New variable. Change-Id: I1e55fc65ff303c309fed50f2071de0eaf4266d57 Maxim Cournoyer 2024-11-12gnu: Add vdrift....* gnu/packages/games.scm (vdrift): New variable. Change-Id: I55b5884a9d7d4a9e874e76c6a7c8af4974dce701 Maxim Cournoyer 2024-11-12gnu: Add vdrift-data....* gnu/packages/games.scm (vdrift-data): New variable. Change-Id: I960e2222ea7e9506a306692db552dc1dcc229b01 Maxim Cournoyer 2024-11-10gnu: ultrastar-deluxe: Update to 2024.10.0....* gnu/packages/games.scm (ultrastar-deluxe): Bump version. [inputs]: Use ffmpeg 6 and ttf output of font-google-noto. Change-Id: I105c352abd8296a73dde54fecdfc6de7692e712e Lars-Dominik Braun 2024-11-06gnu: Rename knights with knightsgame....Rename knights with knightsgame to package knights from KDE games module. * gnu/packages/games.scm (knights): Rename with knightsgame. Change-Id: I6eec8189fd29fe2ede67d98c26fdd9cafe4c2aef Sughosha via Guix-patches via 2024-10-31gnu: odamex: Update to 10.6.0....* gnu/packages/games.scm (odamex): Update to 10.6.0. Change-Id: Ifbad7399f3e43b8a05948d8f7b1b73ba9b30477b David Pflug 2024-10-22gnu: joycond: Update to 0.1.0-2.5b590ec....* gnu/packages/games.scm (joycond): Update to 0.1.0-2.5b590ec. Change-Id: I86a258b6d2992e6b72b4bc4b33b4fdfb2c94e296 Maxim Cournoyer 2024-10-22Revert "gnu: joycond: Update to 0.1.0-2.9d1f509."...Attempt to resolve a new 100% CPU spike problem. This partially reverts commit ecda7d3ef7c1b31d34a4353a2fd637b9d48d75a4. Change-Id: I9f5e05ae926e49367b2a57dad8f5188ddf0ad604 Maxim Cournoyer 2024-10-19gnu: cowsay: Update to 3.8.3....* gnu/packages/games.scm (cowsay): Update to 3.8.3. Change-Id: If6cbf75bec4bf95611356ee54d88c53c1389cf6f Artyom V. Poptsov 2024-10-19gnu: joycond: Patch /bin/setfacl in udev rules....* gnu/packages/games.scm (joycond) [phases]: Extend the 'fix-bin-location' phase. Change-Id: Ie41f822db023369d5d35f9a960a9dadf994663e8 Maxim Cournoyer 2024-10-19gnu: joycond: Update to 0.1.0-2.9d1f509, use gexps and fix license....* gnu/packages/games.scm (joycond): Update to 0.1.0-2.9d1f509. [phases]: Use gexps. [license]: Correct to gpl3+. Change-Id: I81824de94d168e63e0434149805708cb1e8b8a54 Maxim Cournoyer 2024-10-07gnu: jstest-gtk: Mention this is for joydev devices in description....* gnu/packages/games.scm (jstest-gtk) [synopsis]: Mention this is for Joydev joysticks. [description]: Likewise. Change-Id: I3a93a237ea5e2efb6bc49e6a9eee2e8714e25bf5 Maxim Cournoyer 2024-09-29gnu: Add xevil....* gnu/packages/games.scm (xevil): New public variable. Change-Id: I86885cc816685001a7d8d7dacccc396f39ddbd5f Tobias Geerinckx-Rice 2024-09-29gnu: gzdoom: Delete files that might prevent commercial distribution....* gnu/packages/games.scm (gzdoom)[source]: Delete files in the snippet. Change-Id: I601bb251e9b690e375f707786bb5789a6a664b92 Tobias Geerinckx-Rice 2024-09-29gnu: gzdoom: Update package style....* gnu/packages/games.scm (gzdoom)[source]: Don't explicitly return #t from snippet. [arguments]: Likewise from phases. Use G-expressions. Use SEARCH-INPUT-FILE so that we can… [inputs]: …remove input labels. Change-Id: I8dfc4ce55c1c5b5bfda98d81ba54e310b7469766 Tobias Geerinckx-Rice 2024-10-04gnu: moonlight-qt: Update to 6.1.0....* gnu/packages/games.scm (moonlight-qt): Update to 6.1.0. (moonlight-common): Update to submodule checkout. Change-Id: Ia709bcf9684d843f9b24d6a8afd184a79afb1c73 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> dan 2024-10-01gnu: Add AntiMicroX....* gnu/packages/games.scm (antimicrox): New variable. Change-Id: Ie159edf259bba0aa06ff60c074fec4457b409d12 Eric Bavier 2024-09-22gnu: Add sdl-jstest....* gnu/packages/games.scm (sdl-jstest): New variable. Change-Id: I8a2845375501ddadca2eb4add869fce1dc277568 Maxim Cournoyer 2024-09-22gnu: Add evtest-qt....* gnu/packages/games.scm (evtest-qt): New variable. Change-Id: Ifccb54509b4469c923126b100094e06e93383208 Maxim Cournoyer 2024-09-21gnu: Add gemrb-0.9.3....* gnu/packages/games.scm (gemrb-0.9.3): New variable. * gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: Ic05eacf362f9a4ebfe88b1e0967e72e824c4f404 Signed-off-by: Andreas Enge <andreas@enge.fr> Ashvith Shetty 2024-09-08gnu: apricots: Update to 0.2.8....* gnu/packages/games.scm (apricots): Update to 0.2.8. [inputs]: Replace freealut with alure. Change-Id: I3923bbef1a22c9109bda496d76451c03e98e503c Tobias Geerinckx-Rice 2024-09-08gnu: apricots: Disable tests....* gnu/packages/games.scm (apricots)[arguments]: Disable #:tests?. [native-inputs]: Remove cppcheck. Change-Id: I50e7ae3f8e41ffc415d19055e096f3538ada94a2 Tobias Geerinckx-Rice 2024-09-08gnu: armagetronad: Update to 0.2.9.2.3....* gnu/packages/games.scm (armagetronad): Update to 0.2.9.2.3. [arguments]: Add a new 'omit-broken-symlinks phase. Change-Id: I2283e27facdccfb28034434253a2a3b079ceb4c4 Tobias Geerinckx-Rice 2024-09-08gnu: armagetronad: Don't nest everything under games/....* gnu/packages/games.scm (armagetronad)[arguments]: Add ‘--disable-games’ to #:configure-flags. Change-Id: Ie78ed82ff01ad5e14490436169c432160dcbbe0e Tobias Geerinckx-Rice 2024-09-08gnu: armagetronad: Omit uninstaller....* gnu/packages/games.scm (armagetronad)[arguments]: Add ‘--disable-uninstall’ as #:configure-flags. Change-Id: I083108c9ba612c9a8342157c8774177f16a88a76 Tobias Geerinckx-Rice