aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bootloaders.scm3
-rw-r--r--gnu/packages/patches/u-boot-calloc-visibility.patch18
2 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 52a077ecea..da5abaca55 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -758,7 +758,8 @@ tree binary files. These are board description files used by Linux and BSD.")
(patches
(list %u-boot-rockchip-inno-usb-patch
%u-boot-build-without-libcrypto-patch
- %u-boot-allow-disabling-openssl-patch))
+ %u-boot-allow-disabling-openssl-patch
+ (search-patch "u-boot-calloc-visibility.patch")))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"
diff --git a/gnu/packages/patches/u-boot-calloc-visibility.patch b/gnu/packages/patches/u-boot-calloc-visibility.patch
new file mode 100644
index 0000000000..93c52ff709
--- /dev/null
+++ b/gnu/packages/patches/u-boot-calloc-visibility.patch
@@ -0,0 +1,18 @@
+Arrange so that LLVM's shared object doesn't end up using 'calloc' from
+U-Boot's 'malloc_simple.c' when it's initialized.
+
+ https://issues.guix.gnu.org/74270
+
+diff --git a/common/malloc_simple.c b/common/malloc_simple.c
+index 5a8ec538f8..4f5e350a3c 100644
+--- a/common/malloc_simple.c
++++ b/common/malloc_simple.c
+@@ -64,6 +64,8 @@ void *memalign_simple(size_t align, size_t bytes)
+ }
+
+ #if CONFIG_IS_ENABLED(SYS_MALLOC_SIMPLE)
++void *calloc(size_t nmemb, size_t elem_size)
++ __attribute__ ((visibility ("hidden")));
+ void *calloc(size_t nmemb, size_t elem_size)
+ {
+ size_t size = nmemb * elem_size;