aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a94e5c9bc9..a9594905d9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3472,20 +3472,25 @@ UnionFS-FUSE additionally supports copy-on-write.")
(define-public sshfs
(package
(name "sshfs")
- (version "2.10")
+ (version "3.7.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libfuse/sshfs/releases/"
"download/sshfs-" version "/sshfs-" version
- ".tar.gz"))
+ ".tar.xz"))
(sha256
(base32
- "00fir2iykdx11g8nv5gijg0zjrp2g3ldypnv0yi6lq3h5pg5v13h"))))
- (build-system gnu-build-system)
+ "169fkilv060afgp9h7hvsbkg02bd1y77kmx06x0s7q1cvmxww62j"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; XXX: tests are skipped: FUSE kernel module does not seem to be loaded
+ '(#:tests? #f))
(inputs
- (list fuse glib))
+ (list fuse-3 glib))
(native-inputs
- (list pkg-config))
+ (list pkg-config
+ ;; man page
+ python-docutils))
(home-page "https://github.com/libfuse/sshfs")
(synopsis "Mount remote file systems over SSH")
(description
Mathieu Othacehe 2020-06-16etc: Add committer script....Ricardo Wurmus 2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès 2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer 2020-04-23build: Don't build man pages when cross-compiling....Ludovic Courtès 2020-03-11build: Require Guile 2.2.3 or later....Ludovic Courtès 2020-01-17build: Allow builds with Guile 3.0....Ludovic Courtès 2019-11-09build: Warn about etc/indent-code.el when Emacs is absent....zimoun