aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6513c609cf..a831f41839 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3203,14 +3203,15 @@ fullscreen, use F5 or Alt+Enter.")
(package
(name "warzone2100")
(version "3.2.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/" name
- "/releases/" version "/" name "-" version
- ".tar.xz"))
- (sha256
- (base32
- "10kmpr4cby95zwqsl1zwx95d9achli6khq7flv6xmrq30a39xazw"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/warzone2100/archives/"
+ "unsupported/Warzone2100-"
+ (version-major+minor version) "/" version
+ "/warzone2100-" version ".tar.xz"))
+ (sha256
+ (base32 "10kmpr4cby95zwqsl1zwx95d9achli6khq7flv6xmrq30a39xazw"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-distributor=Guix")
hasn't seen a release
; in four years and cannot be built.
+ #:phases
+ (modify-phases %standard-phases
+ ;; The build system attempts to install user interface modules to the
+ ;; output directory of the "evolution-data-server" package. This
+ ;; change redirects that change.
+ (add-after 'unpack 'patch-ui-module-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/modules/alarm-notify/CMakeLists.txt"
+ (("\\$\\{edsuimoduledir\\}")
+ (string-append (assoc-ref outputs "out")
+ "/lib/evolution-data-server/ui-modules")))
+ #t))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'install 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
`(("glib" ,glib "bin") ; glib-mkenums
("pkg-config" ,pkg-config)