;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu system install) #:use-module (gnu) #:use-module (guix gexp) #:use-module (guix store) #:use-module (guix monads) #:use-module ((guix store) #:select (%store-prefix)) #:use-module (guix profiles) #:use-module (gnu packages admin) #:use-module (gnu packages linux) #:use-module (gnu pack
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ld-wrapper.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ld-wrapper.scm b/gnu/packages/ld-wrapper.scm
index 41ff3df986..d3eb083f2f 100644
--- a/gnu/packages/ld-wrapper.scm
+++ b/gnu/packages/ld-wrapper.scm
@@ -11,7 +11,7 @@ main="(@ (gnu build-support ld-wrapper) ld-wrapper)"
exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "$@"
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,7 +63,7 @@ exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "
(define %store-directory
;; File name of the store.
- (or (getenv "NIX_STORE") "/nix/store"))
+ (or (getenv "NIX_STORE") "/gnu/store"))
(define %temporary-directory
;; Temporary directory.
(string-append target #$%backing-directory)))))))) (define (configuration-template-service) "Return a dummy service whose purpose is to install an operating system configuration template file in the installation system." (define local-template "/etc/configuration-template.scm") (define template (search-path %load-path "gnu/system/os-config.tmpl")) (mlet %store-monad ((template (interned-file template))) (return (service (requirement '(root-file-system)) (provision '(os-config-template)) (documentation "This dummy service installs an OS configuration template.") (start #~(const #t)) (stop #~(const #f)) (activate #~(unless (file-exists? #$local-template) (copy-file #$template #$local-template))))))) (define %nscd-minimal-caches ;; Minimal in-memory caching policy for nscd. (list (nscd-cache (database 'hosts) (positive-time-to-live (* 3600 12)) (negative-time-to-live 20) (persistent? #f) (max-database-size (* 5 (expt 2 20)))))) ;5 MiB (define (installation-services) "Return the list services for the installation image." (let ((motd (text-file "motd" " Welcome to the installation of the Guix System Distribution! There is NO WARRANTY, to the extent permitted by law. In particular, you may LOSE ALL YOUR DATA as a side effect of the installation process. Furthermore, it is alpha software, so it may BREAK IN UNEXPECTED WAYS. You have been warned. Thanks for being so brave. "))) (define (normal-tty tty) (mingetty-service tty #:motd motd #:auto-login "root" #:login-pause? #t)) (list (mingetty-service "tty1" #:motd motd #:auto-login "root") ;; Documentation. The manual is in UTF-8, but ;; 'console-font-service' sets up Unicode support and loads a font ;; with all the useful glyphs like em dash and quotation marks. (mingetty-service "tty2" #:motd motd #:auto-login "guest" #:login-program (log-to-info)) ;; Documentation add-on. (configuration-template-service) ;; A bunch of 'root' ttys. (normal-tty "tty3") (normal-tty "tty4") (normal-tty "tty5") (normal-tty "tty6") ;; The usual services. (syslog-service) ;; The build daemon. Register the hydra.gnu.org key as trusted. ;; This allows the installation process to use substitutes by ;; default. (guix-service #:authorize-hydra-key? #t) ;; Start udev so that useful device nodes are available. (udev-service) ;; Add the 'cow-store' service, which users have to start manually ;; since it takes the installation directory as an argument. (cow-store-service) ;; Install Unicode support and a suitable font. (console-font-service "tty1") (console-font-service "tty2") (console-font-service "tty3") (console-font-service "tty4") (console-font-service "tty5") (console-font-service "tty6") ;; Since this is running on a USB stick with a unionfs as the root ;; file system, use an appropriate cache configuration. (nscd-service (nscd-configuration (caches %nscd-minimal-caches)))))) (define %issue ;; Greeting. " This is an installation image of the GNU system. Welcome. Use Alt-F2 for documentation. ") (define installation-os ;; The operating system used on installation images for USB sticks etc. (operating-system (host-name "gnu") (timezone "Europe/Paris") (locale "en_US.utf8") (bootloader (grub-configuration (device "/dev/sda"))) (file-systems ;; Note: the disk image build code overrides this root file system with ;; the appropriate one. (cons (file-system (mount-point "/") (device "gnu-disk-image") (type "ext4")) %base-file-systems)) (users (list (user-account (name "guest") (group "users") (supplementary-groups '("wheel")) ; allow use of sudo (password "") (comment "Guest of GNU") (home-directory "/home/guest")))) (issue %issue) (services (installation-services)) ;; We don't need setuid programs so pass the empty list so we don't pull ;; additional programs here. (setuid-programs '()) (pam-services ;; Explicitly allow for empty passwords. (base-pam-services #:allow-empty-passwords? #t)) (packages (cons* texinfo-4 ;for the standalone Info reader parted ddrescue grub ;mostly so xrefs to its manual work cryptsetup wireless-tools iw wpa-supplicant-light ;; XXX: We used to have GNU fdisk here, but as of version ;; 2.0.0a, that pulls Guile 1.8, which takes unreasonable ;; space; furthermore util-linux's fdisk is already ;; available here, so we keep that. %base-packages)))) ;; Return it here so 'guix system' can consume it directly. installation-os ;;; install.scm ends here