aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm15
-rw-r--r--gnu/packages/shells.scm5
2 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 991d2e3a2e..b00b33ca38 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -481,11 +481,13 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
(version "3.9.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.gnuradio.org/releases/gnuradio/"
- "gnuradio-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnuradio/gnuradio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1jvm9xd0l2pz1fww4zii6hl7ccnvy256nrf70ljb594n7j9j49ha"))))
+ (base32 "1fbl8lslzrkx7lpkibhvs6gvhqnn8yrrq3n6irybfnifh2536d36"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -550,6 +552,11 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
"/share/javascript/mathjax"))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-source-writable
+ (lambda _
+ ;; The test_add and test_newmod open(sources, "w") for some reason.
+ (for-each make-file-writable
+ (find-files "." ".*"))))
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((qwt (assoc-ref inputs "qwt")))
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index f080d71c40..f1c13dc1bd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -945,7 +945,7 @@ files and text.")
(define-public nushell
(package
(name "nushell")
- (version "0.32.0")
+ (version "0.33.0")
(source
(origin
(method git-fetch)
@@ -954,7 +954,7 @@ files and text.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1wj054rzv88ys4ask4zp7crrw0dxrck8svlj3i16qqd8x5dnyhqs"))))
+ (base32 "0rdvvg6hf01bljq0zz0c66kbzy5ggbcbil1j45hklzq0ibffdj02"))))
(build-system cargo-build-system)
(arguments
`(#:rust ,rust-1.47
@@ -995,6 +995,7 @@ files and text.")
("rust-nu-plugin-to-sqlite" ,rust-nu-plugin-to-sqlite-0.32)
("rust-nu-plugin-tree" ,rust-nu-plugin-tree-0.32)
("rust-nu-plugin-xpath" ,rust-nu-plugin-xpath-0.32)
+ ("rust-polars-0.13" ,rust-polars-0.13)
("rust-pretty-env-logger" ,rust-pretty-env-logger-0.4))
#:cargo-development-inputs
(("rust-dunce" ,rust-dunce-1)
9ece3d643dec3'>serialization: Add #:select? parameter to 'write-file'....* guix/serialization.scm (write-file): Add #:select? parameter and honor it. * tests/nar.scm ("write-file #:select? + restore-file"): New test. Ludovic Courtès 2016-04-03build: Add a Guile custom test driver using SRFI-64....Before that '.log' files for scheme tests were fragmented and not included in test-suite.log. This unifies the semantics of SRFI-64 API with Automake test suite. * build-aux/test-driver.scm: New file. * Makefile.am (SCM_LOG_DRIVER, AM_SCM_LOG_DRIVER_FLAGS): New variables. (SCM_LOG_COMPILER, AM_SCM_LOG_FLAGS): Delete variables. (AM_TESTS_ENVIRONMENT): Set GUILE_AUTO_COMPILE to 0. * test-env.in: Silence guix-daemon. * doc/guix.texi (Running the Test Suite): Describe how to display the detailed results. Bug reports require only 'test-suite.log' file. * tests/base32.scm, tests/build-utils.scm, tests/builders.scm, tests/challenge.scm, tests/cpan.scm, tests/cpio.scm, tests/cran.scm, tests/cve.scm, tests/derivations.scm, tests/elpa.scm, tests/file-systems.scm, tests/gem.scm, tests/gexp.scm, tests/gnu-maintenance.scm, tests/grafts.scm, tests/graph.scm, tests/gremlin.scm, tests/hackage.scm, tests/hash.scm, tests/import-utils.scm, tests/lint.scm, tests/monads.scm, tests/nar.scm, tests/packages.scm, tests/pk-crypto.scm, tests/pki.scm, tests/profiles.scm, tests/publish.scm, tests/pypi.scm, tests/records.scm, tests/scripts-build.scm, tests/scripts.scm, tests/services.scm, tests/sets.scm, tests/size.scm, tests/snix.scm, tests/store.scm, tests/substitute.scm, tests/syscalls.scm, tests/system.scm, tests/ui.scm, tests/union.scm, tests/upstream.scm, tests/utils.scm: Don't exit at the end of test groups. * tests/containers.scm: Likewise. Use 'test-skip' instead of exiting with error code 77. Mathieu Lirzin 2015-08-26tests: Work around Btrfs handling of nlink for empty directories....Fixes <http://bugs.gnu.org/21280>. Reported by Leo Famulari <leo@famulari.name>. * tests/nar.scm (file-tree-equal?): Use #t as the initial result. Btrfs would set nlink to 1 instead of 2 for an empty directory, thereby leading 'file-tree-equal?' to return #f. Ludovic Courtès 2015-06-24tests: Move 'file=?' to (guix tests)....* tests/nar.scm (file-tree-equal?)[file=?]: Move to... * guix/tests.scm (file=?): ... here. New procedure. Ludovic Courtès 2015-02-07serialization: Check for EOF and incomplete input conditions....Fixes <http://bugs.gnu.org/19756>. Reported by <sleep_walker@suse.cz>. * guix/serialization.scm (currently-restored-file): New variable. (get-bytevector-n*): New procedure. (read-int, read-long-long, read-string, read-latin1-string, read-contents): Use it instead of 'get-bytevector-n'. (restore-file): Parameterize 'currently-restored-file' and set it. * tests/nar.scm ("restore-file with incomplete input"): New test. Ludovic Courtès 2014-11-04tests: When a store item is to be deleted, make it statistically unique....Fixes <http://bugs.gnu.org/18935>. Reported by Mark H Weaver <mhw@netris.org>. Previously, if tests/nar.scm ran concurrently with tests/gexp.scm, the store item "foo" containing the string "Hello, world!" could be deleted (via 'delete-paths') from the tests/nar.scm daemon while the tests/gexp.scm daemon would still consider it live. * tests/nar.scm ("restore-file-set (missing signature)"): Use (random-text) rather than "Hello, world!", to avoid concurrent deletion of store item "foo" used in tests/gexp.scm. Ludovic Courtès 2014-10-09Break module cycle involving (guix store) and (guix ui)....Before, there was a cycle along the lines of: (guix store) -> (guix nar) -> (guix ui) -> (guix store) This caused problems, as discussed at: http://lists.gnu.org/archive/html/guix-devel/2014-10/msg00109.html This patch removes cycles in the (guix ...) modules. * guix/nar.scm (&nar-error, &nar-read-error, dump, write-contents, read-contents, %archive-version-1, write-file, restore-file): Move to... * guix/serialization.scm: ... here. * guix/store.scm: Remove dependency on (guix nar). * guix/scripts/hash.scm, guix/scripts/offload.scm, guix/scripts/substitute-binary.scm, tests/nar.scm, tests/store.scm, tests/substitute-binary.scm: Adjust accordingly. Ludovic Courtès 2014-08-23Factorize test suite support in (guix tests)....* guix/tests.scm: New file. * Makefile.am (noinst_DATA): New variable. (GOBJECTS): Add guix/tests.go. * tests/builders.scm (%store): Use 'open-connection-for-tests' from (guix tests). * tests/derivations.scm: Likewise. * tests/monads.scm: Likewise. * tests/packages.scm: Likewise. * tests/profiles.scm: Likewise. * tests/union.scm: Likewise. * tests/gexp.scm: Likewise. (guile-for-build): Remove. Use (%guile-for-build) instead. * tests/nar.scm (make-random-bytevector, %seed, random-text): Remove. (populate-file): Change 'make-random-bytevector' to 'random-bytevector'. Use (guix tests). * tests/store.scm (%seed, random-text): Remove. Use (guix tests). Ludovic Courtès 2014-02-21nar: Produce archives with files sorted in C collation order....* guix/nar.scm (write-file) <directory>: Pass 'string<?' as the second argument to 'scandir'. * tests/nar.scm ("write-file puts file in C locale collation order"): New test. Ludovic Courtès 2014-02-21nar: 'write-file' can write to non-file ports....* guix/nar.scm (write-contents): Use 'sendfile' only when P is a file port. * tests/nar.scm ("write-file supports non-file output ports"): New test. Ludovic Courtès 2014-01-24nar: Add 'restore-file-set', for use by build hooks....* guix/nar.scm (&nar-invalid-hash-error, &nar-signature-error): New condition types. (&nar-error): Add 'file' and 'port' fields. (&nar-read-error): Remove 'port' and 'file' fields. (lock-store-file, unlock-store-file, finalize-store-file, temporary-store-directory, restore-file-set): New procedures. * tests/nar.scm (%seed): New variable. (random-text): New procedure. ("restore-file-set (signed, valid)", "restore-file-set (missing signature)", "restore-file-set (corrupt)"): New tests. * po/Makevars (XGETTEXT_OPTIONS): Add '--keyword=message'.nar fixes * po/POTFILES.in: Add guix/nar.scm. Ludovic Courtès 2013-05-11tests: Fix out-of-source builds....* tests/nar.scm (%test-dir): Compute relative to `pre-inst-env', which is in $top_builddir. Ludovic Courtès 2013-04-12tests: Remove temporary directory created by nar.scm....* tests/nar.scm ("write-file + restore-file with symlinks"): Add (rm-rf output). Ludovic Courtès 2013-04-12nar: Add support for symlinks....* guix/nar.scm (write-file): Add case for type `symlink'. (restore-file): Likewise. * tests/nar.scm (random-file-size, make-file-tree, delete-file-tree, with-file-tree, file-tree-equal?, make-random-bytevector, populate-file): New procedures. (%test-dir): New variable. ("write-file + restore-file"): Use `%test-dir' and `file-tree-equal?'. ("write-file + restore-file with symlinks"): New test. Ludovic Courtès 2013-04-08nar: Implement restoration from Nar....* guix/nar.scm (&nar-error, &nar-read-error): New condition types. (dump): New procedure. (write-contents)[dump]: Remove. Use the one above instead. (read-contents, write-file, restore-file): New procedures. (%archive-version-1): New variable. Ludovic Courtès