aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-web.scm22
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 20b68705cb..2aefb0f037 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2078,6 +2078,28 @@ GitHub API v3.")
parameters.")
(license license:bsd-3)))
+(define-public go-github-com-google-gopacket
+ (package
+ (name "go-github-com-google-gopacket")
+ (version "1.1.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gopacket")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "048qwm2n0wrpql4qqgd7jyynn3gk069yvqbxnshlayzmbhf87ls4"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/google/gopacket"))
+ (home-page "https://github.com/google/gopacket")
+ (synopsis "Packet processing capabilities library")
+ (description
+ "This package provides packet processing capabilities for Go.")
+ (license license:bsd-3)))
+
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2cf7773c3b..3abf668a02 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5290,28 +5290,6 @@ a cron spec parser and job runner.")
"This is a fork of another go-libvterm library for use with aerc.")
(license license:expat))))
-(define-public go-github-com-google-gopacket
- (package
- (name "go-github-com-google-gopacket")
- (version "1.1.19")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/gopacket")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "048qwm2n0wrpql4qqgd7jyynn3gk069yvqbxnshlayzmbhf87ls4"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/gopacket"))
- (home-page "https://github.com/google/gopacket")
- (synopsis "Packet processing capabilities library")
- (description
- "This package provides packet processing capabilities for Go.")
- (license license:bsd-3)))
-
(define (go-gotest-tools-source version sha256-base32-hash)
(origin
(method git-fetch)