aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnunet.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index b08479624d..7f7a6fd6f9 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -167,20 +167,13 @@ and support for SSL3 and TLS.")
"--disable-file" "--disable-ftp")
#:test-target "test"
#:parallel-tests? #f
- ;; We have to patch runtests.pl in tests/ directory and add a failing
- ;; test due to curl->gnurl name change to tests/data/DISABLED
+ ;; We have to patch runtests.pl in tests/ directory
#:phases
(alist-cons-before
'check 'patch-runtests
(lambda _
- (with-directory-excursion "tests"
- (substitute* "runtests.pl"
- (("/bin/sh")
- (which "sh")))
- (let* ((port (open-file "data/DISABLED" "a")))
- (newline port)
- (display "1022" port)
- (close port))))
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh"))))
%standard-phases)))
(synopsis "Microfork of cURL with support for the HTTP/HTTPS/GnuTLS subset of cURL")
(description
ls.el: Add guix yasnippets....Andrew Tropin 2022-07-10monads: Add 'mparameterize'....Ludovic Courtès 2022-07-10.dir-locals.el: Restore Emacs 27 lisp-fill-paragraph behavior....Maxim Cournoyer 2022-06-28.dir-locals.el: Properly indent 'wrap-script'....Maxim Cournoyer 2022-06-07.dir-locals: Adjust to bug-reference-mode in Emacs 28....Ludovic Courtès 2022-03-06import: github: Reuse HTTP connection for the /tags URL fallback....Ludovic Courtès 2022-03-06tests: Add (guix http-client) tests....Ludovic Courtès 2022-01-29.dir-locals.el: Don't mess up indentation of prepend and append....Liliana Marie Prikler 2021-08-12Merge branch 'master' into core-updates-frozen...Marius Bakke 2021-08-02.dir-locals.el: Specify indentation rule for with-shepherd-action....Maxim Cournoyer 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-11packages: Add 'modify-inputs'....Ludovic Courtès 2021-06-29pack: Add support for the deb format....Maxim Cournoyer