aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm146
-rw-r--r--gnu/packages/xml.scm33
2 files changed, 178 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eefe75de1e..35af94f4fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages scanner)
+ #:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
@@ -181,6 +183,50 @@ Gnome project. It includes xml2po tool which makes it easier to translate
and keep up to date translations of documentation.")
(license license:gpl2+))) ; xslt under lgpl
+(define-public gcr
+ (package
+ (name "gcr")
+ (version "3.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0xfhi0w358lvca1jjx24x2gm67mif33dsnmi9cv5i0f83ks8vzpc"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;25 of 598 tests fail because /var/lib/dbus/machine-id does
+ ;not exist
+ #:phases (modify-phases %standard-phases
+ (add-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "build/tap-driver"
+ (("/usr/bin/env python") (which "python"))))))))
+ (inputs
+ `(("dbus" ,dbus)
+ ("gnupg" ,gnupg) ;called as a child process during tests
+ ("libgcrypt" ,libgcrypt)))
+ (native-inputs
+ `(("python" ,python-2) ;for tests
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
+ ("intltool" ,intltool)))
+ ;; mentioned in gck.pc, gcr.pc and gcr-ui.pc
+ (propagated-inputs
+ `(("p11-kit" ,p11-kit)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)))
+ (home-page "http://www.gnome.org")
+ (synopsis "Libraries for displaying certificates and accessing key stores")
+ (description
+ "The GCR package contains libraries used for displaying certificates and
+accessing key stores. It also provides the viewer for crypto files on the
+GNOME Desktop.")
+ (license license:lgpl2.1+)))
+
(define-public libgnome-keyring
(package
(name "libgnome-keyring")
@@ -212,6 +258,73 @@ and keep up to date translations of documentation.")
;; Though a couple of files are LGPLv2.1+.
(license license:lgpl2.0+)))
+(define-public gnome-keyring
+ (package
+ (name "gnome-keyring")
+ (version "3.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1xg1xha3x3hzlmvdq2zm90hc61pj7pnf9yxxvgq4ynl5af6bp8qm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;48 of 603 tests fail because /var/lib/dbus/machine-id does
+ ;not exist
+ #:configure-flags
+ (list
+ (string-append "--with-pkcs11-config="
+ (assoc-ref %outputs "out") "/share/p11-kit/modules/")
+ (string-append "--with-pkcs11-modules="
+ (assoc-ref %outputs "out") "/share/p11-kit/modules/"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "build/tap-driver"
+ (("/usr/bin/env python") (which "python")))))
+ (add-before
+ 'configure 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "docs/Makefile.am"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ (setenv "XML_CATALOG_FILES"
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml")))))))
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("dbus" ,dbus)
+ ("gcr" ,gcr)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
+ ("python" ,python-2) ;for tests
+ ("intltool" ,intltool)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libxslt" ,libxslt) ;for documentation
+ ("docbook-xml" ,docbook-xml-4.2)
+ ("docbook-xsl" ,docbook-xsl)))
+ (home-page "http://www.gnome.org")
+ (synopsis "Daemon to store passwords and encryption keys")
+ (description
+ "gnome-keyring is a program that keeps passwords and other secrets for
+users. It is run as a daemon in the session, similar to ssh-agent, and other
+applications locate it via an environment variable or D-Bus.
+
+The program can manage several keyrings, each with its own master password,
+and there is also a session keyring which is never stored to disk, but
+forgotten when the session ends.")
+ (license license:lgpl2.1+)))
+
(define-public evince
(package
(name "evince")
@@ -1412,6 +1525,39 @@ engineering.")
"The default GNOME 3 themes (Adwaita and some accessibility themes).")
(license license:lgpl2.1+)))
+(define-public seahorse
+ (package
+ (name "seahorse")
+ (version "3.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0cg1grgpwbfkiny5148n17rzpc8kswyr5yff0kpm8l3lp01my2kp"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gcr" ,gcr)
+ ("gnupg" ,gnupg-1)
+ ("gpgme" ,gpgme)
+ ("openssh" ,openssh)
+ ("libsecret" ,libsecret)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("glib:bin" ,glib "bin")
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://launchpad.net/gnome-themes-standard")
+ (synopsis "Manage encryption keys and passwords in the GNOME keyring")
+ (description
+ "Seahorse is a GNOME application for managing encryption keys and
+passwords in the GNOME keyring.")
+ (license license:gpl2+)))
+
(define-public vala
(package
(name "vala")
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d30c40ce1a..8a4d2fbb5b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -20,8 +20,10 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gnutls)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages web)
@@ -387,3 +389,32 @@ that conforms to the API of the Document Object Model.")
stylesheet for the conversion you want and applies it using an external
XSL-T processor. It also performs any necessary post-processing.")
(license license:gpl2+)))
+
+(define-public xmlsec
+ (package
+ (name "xmlsec")
+ (version "1.2.20")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.aleksey.com/xmlsec/download/"
+ name "1-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01bkbv2y3x8d1sf4dcln1x3y2jyj391s3208d9a2ndhglly5j89j"))))
+ (build-system gnu-build-system)
+ (propagated-inputs ; according to xmlsec1.pc
+ `(("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("libgcrypt" ,libgcrypt)
+ ("libltdl" ,libltdl)))
+ (home-page "http://www.libexpat.org/")
+ (synopsis "XML Security Library")
+ (description
+ "The XML Security Library is a C library based on Libxml2. It
+supports XML security standards such as XML Signature, XML Encryption,
+Canonical XML (part of Libxml2) and Exclusive Canonical XML (part of
+Libxml2).")
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))