aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ba235d3538..d46d16c91e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -835,20 +835,32 @@ ASGI server.")
(define-public python-a2wsgi
(package
(name "python-a2wsgi")
- (version "1.7.0")
+ (version "1.10.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "a2wsgi" version))
(sha256
(base32
- "1cmsbgfg0vp8pwqz8nmkbmdi0axis1yl34qb280h5ssh08ngc1m9"))))
+ "13ikyfmkx7hlrbg5rpcdm6kw4wcsy00giil3f72hpb6sw7vjyinf"))))
(build-system pyproject-build-system)
(arguments
- (list #:build-backend "pdm.backend"
- ;; Tests have a circular dependency on uvicorn.
- #:tests? #f))
- (native-inputs
- (list python-pdm-backend))
+ (list
+ #:test-flags
+ #~(list "-k" (string-join
+ (list "not test_starlette_stream_response"
+ "test_starlette_base_http_middleware"
+ "test_baize_stream_response")
+ " and not "))
+ #:build-backend "pdm.backend"))
+ (native-inputs
+ (list python-pdm-backend
+ python-pytest
+ ;; python-baize ; not packed yet
+ python-httpx-bootstrap
+ ;; Cycle: python-a2wsgi->python-uvicorn->
+ ;; python-httpx->python-starlette->python-a2wsgi
+ ;; python-starlette
+ python-pytest-asyncio))
(home-page "https://github.com/abersheeran/a2wsgi")
(synopsis "Convert WSGI to ASGI or vice versa")
(description
rements phase. [native-inputs]: Remove python-docutils. Add python-openstackdocstheme and python-reno. (python2-oslosphinx): Remove variable. Maxim Cournoyer 2020-11-19gnu: python-oslosphinx: Fix indentation....* gnu/packages/openstack.scm (python-oslosphinx): Fix indentation. Maxim Cournoyer 2020-11-19gnu: python-oslo: Update to 3.1.1....* gnu/packages/openstack.scm (python-oslo): Update to 3.1.1. [phases]: Add new 'relax-requirements phase. [propagated-inputs]: Move python-pbr... [native-inputs]: ...here. Add python-bandit, python-coverage and python-stestr. Maxim Cournoyer 2020-11-19gnu: python-hacking: Update to 4.0.0....Fixes <https://issues.guix.gnu.org/39871>. * gnu/packages/openstack.scm (python-hacking): Update to 4.0.0. [arguments]: Remove field. [propagated-inputs]: Remove python-flake8-2.6, python-mccabe-0.2.1, python-pbr, python-pep8-1.5.7, python-pyflakes-1.2, python-six. Add python-flake8. [native-inputs]: Remove python-reno and python-testrepository. Add python-coverage, python-ddt, python-dnspython, python-fixtures, python-monotonic, python-subunit, python-stestr and python-testtools. (python2-hacking): Remove variable. * gnu/packages/python-xyz.scm (python-pyflakes-1.2) (python-mccabe-0.2.1, python2-mccabe-0.2.1) (python-pep8-1.5.7, python2-pep8-1.5.7) (python-flake8-2.6): Delete variables. Maxim Cournoyer 2020-11-19gnu: Add python-cliff....* gnu/packages/openstack.scm (python-cliff): New variable. Maxim Cournoyer 2020-11-19gnu: python-bandit: Fix indentation....* gnu/packages/openstack.scm (python-bandit): Fix indentation. Maxim Cournoyer 2020-11-19gnu: python-bandit: Update to 1.6.2....* gnu/packages/openstack.scm (python-bandit): Update to 1.6.2. [phases]: Remove argument. [tests?]: Disable test suite. [native-inputs]: Remove python-beautifulsoup4, python-fixtures, python-mock, python-subunit, python-testrepository, python-testscenarios and python-testtools. Add python-pbr. Maxim Cournoyer 2020-11-19gnu: python-oslotest: Update to 4.4.1....* gnu/packages/openstack.scm (python-oslotest): Update to 4.4.1. [tests?]: Disable test suite. [propagated-inputs]: Remove python-mock, python-mox3, python-os-client-config and python-testrepository. [native-inputs]: Remove field. Maxim Cournoyer 2020-11-19gnu: python-oslotest: Re-indent....* gnu/packages/openstack.scm (python-oslotest): Fix indentation. Maxim Cournoyer 2020-11-19gnu: python-stevedore: Update to 3.2.2....* gnu/packages/openstack.scm (python-stevedore): Update to 3.2.2. [tests?]: Disable tests. [propagated-inputs]: Remove field. Move python-pbr to... [native-inputs]: ...here. Remove python-mock, python-sphinx and python-testrepository. Maxim Cournoyer