aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f337d5f6c6..289cc29917 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3216,7 +3216,7 @@ alpha blending etc).")
(define-public frei0r-plugins
(package
(name "frei0r-plugins")
- (version "1.6.1")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
@@ -3224,23 +3224,25 @@ alpha blending etc).")
"frei0r-plugins-" version ".tar.gz"))
(sha256
(base32
- "0pji26fpd0dqrx1akyhqi6729s394irl73dacnyxk58ijqq4dhp0"))))
+ "0fjji3060r4fwr7vn91lwfzl80lg3my9lkp94kbyw8xwz7qgh7qv"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autotools
+ (add-after 'unpack 'patch-Makefile
(lambda _
- (invoke "sh" "autogen.sh"))))))
+ ;; XXX: The 1.7.0 Makefile looks for files that have slightly different
+ ;; names in the tarball. Try removing this for future versions.
+ (substitute* "Makefile.in"
+ (("README\\.md ChangeLog TODO AUTHORS")
+ "README.txt ChangeLog.txt TODO.txt AUTHORS.txt"))
+ #t)))))
;; TODO: opencv for additional face detection filters.
(inputs
`(("gavl" ,gavl)
("cairo" ,cairo)))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("libtool" ,libtool)
- ("automake" ,automake)
- ("autoconf" ,autoconf)))
+ `(("pkg-config" ,pkg-config)))
(home-page "https://www.dyne.org/software/frei0r/")
(synopsis "Minimalistic plugin API for video effects")
(description
'>...Fixes: <https://issues.guix.gnu.org/43533>. * gnu/build/shepherd.scm (fork+exec-command/container): Check if containers are supported before joining PID namespaces. Mathieu Othacehe 2020-09-02installer: Run the installation inside a container....When the store overlay is mounted, other processes such as kmscon, udev and guix-daemon may open files from the store, preventing the underlying install support from being umounted. See: https://lists.gnu.org/archive/html/guix-devel/2018-12/msg00161.html. To avoid this situation, mount the store overlay inside a container, and run the installation from within that container. * gnu/build/shepherd.scm (fork+exec-command/container): New procedure. * gnu/services/base.scm (guix-shepherd-service): Support an optional PID argument passed to the "start" method. If that argument is passed, ensure that guix-daemon enters the given PID MNT namespace by using fork+exec-command/container procedure. * gnu/installer/final.scm (umount-cow-store): Remove it, (install-system): run the installation from within a container. * gnu/installer/newt/final.scm (run-install-shell): Remove the display hack. Mathieu Othacehe