aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cups.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index e8f972c34a..2ce4045675 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -263,6 +263,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(package
(name "cups-minimal")
(version "2.4.9")
+ (replacement cups-minimal/fixed)
(source
(origin
(method git-fetch)
@@ -352,6 +353,21 @@ applications''. These must be installed separately.")
;; CUPS is Apache 2.0 with exceptions, see the NOTICE file.
(license license:asl2.0)))
+(define cups-minimal/fixed
+ (package
+ (inherit cups-minimal)
+ (version "2.4.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenPrinting/cups")
+ (commit (string-append "v" version))))
+ ;; Avoid NAME confusion: these are the complete CUPS sources.
+ (file-name (git-file-name "cups" version))
+ (sha256
+ (base32 "0mqx302mnk728h9sq5lknfv3ip7mfv44x3cqrjpndcdffd0ppnsw"))))))
+
(define-public cups
(package/inherit cups-minimal
(name "cups")