aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-windows.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 4d4f547d01..eb3ca339ba 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -1806,6 +1806,25 @@ crate.")
(base32
"12hx7qpsjg9p7jggfcplqa3mf1mzr7k7s5ybzqwg1zmg4fn2aizm"))))))
+(define-public rust-windows-i686-gnullvm-0.52
+ (package
+ (name "rust-windows-i686-gnullvm")
+ (version "0.52.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows_i686_gnullvm" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0rpdx1537mw6slcpqa0rm3qixmsb79nbhqy5fsm3q2q9ik9m5vhf"))
+ (snippet
+ '(delete-file "lib/libwindows.0.52.0.a"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Import lib for Windows")
+ (description "This package provides Import lib for Windows.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-i686-msvc-0.52
(package
(name "rust-windows-i686-msvc")
inimal `(,glib "bin") ; for glib-compile-resources gsettings-desktop-schemas ; for the org.gnome.system.proxy schema pkg-config)) (inputs (list bash-minimal ; for wrap-program gst-plugins-bad gst-plugins-base gst-plugins-good gstreamer gtk gtksourceview json-glib libadwaita libgee libsoup-minimal libsecret libwebp libxml2 vala webp-pixbuf-loader)) (home-page "https://tuba.geopjr.dev/") (synopsis "GTK client for Mastodon") (description "Tuba is a GTK client for Mastodon. It provides a clean, native interface that allows you to integrate Mastodon's social experience seamlessly with your desktop environment.") (license license:gpl3))) (define-public tootle (deprecated-package "tootle" tuba)) (define-public python-mastodon-py (package (name "python-mastodon-py") (version "1.5.1") (source (origin (method url-fetch) (uri (pypi-uri "Mastodon.py" version)) (sha256 (base32 "1vikvkzcij2gd730cssigxi38vlmzqmwdy58r3y2cwsxifnxpz9a")))) (build-system python-build-system) (propagated-inputs (list python-blurhash python-dateutil python-decorator python-magic python-pytz python-requests python-six)) (native-inputs (list python-blurhash python-cryptography python-http-ece python-pytest python-pytest-cov python-pytest-mock python-pytest-runner python-pytest-vcr python-requests-mock python-vcrpy)) (home-page "https://github.com/halcy/Mastodon.py") (synopsis "Python wrapper for the Mastodon API") (description "This package provides a python wrapper for the Mastodon API.") (license license:expat))) (define-public snac2 (package (name "snac") (version "2.65") (source (origin (method git-fetch) (uri (git-reference (url "https://codeberg.org/grunfink/snac2") (commit version))) (file-name (git-file-name name version)) (sha256 (base32 "06npcsf8jkcygsh586wnsq6cr1cn46n3s8zx3inbjgh99sc24fcg")))) (build-system gnu-build-system) (inputs (list curl openssl)) (arguments (list #:phases #~(modify-phases %standard-phases (delete 'configure) (add-after 'unpack 'remove-usr-local (lambda _ (substitute* "Makefile" (("-I/usr/local/include") "") (("-L/usr/local/lib") ""))))) #:tests? #f ; no test target #:make-flags #~(list (string-append "CC=" #$(cc-for-target)) (string-append "CFLAGS=-O2 -g -Wall -Wextra") (string-append "PREFIX=" #$output) (string-append "PREFIX_MAN=" #$output "/share/man")))) (home-page "https://codeberg.org/grunfink/snac2") (synopsis "Simple, minimalistic ActivityPub instance written in portable C") (description "Snac is a simple, minimalistic ActivityPub instance written in portable C. It features: @itemize @item Lightweight, minimal dependencies @item Extensive support of ActivityPub operations, e.g. write public notes, follow users, be followed, reply to the notes of others, admire wonderful content (like or boost), write private messages, etc. @item Multiuser support @item Mastodon API support, so Mastodon-compatible apps can be used @item Simple but effective web interface @item Easily-accessed MUTE button to silence users @item Tested interoperability with related software @item No database needed @item Totally JavaScript-free; no cookies either @end itemize") (license license:expat)))