aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 13299fdf06..2760a90eab 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2018, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Alex Vong <alexvong1995@gmail.com>
@@ -1523,17 +1523,17 @@ quality and performance.")
(define-public libva
(package
(name "libva")
- (version "2.15.0")
+ (version "2.17.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/intel/libva/releases/download/"
version "/libva-" version ".tar.bz2"))
(sha256
- (base32 "1jhy8qzfp4ydbxs9qd9km7k5wq8r4s2vq20r1q07lgld8l4x93i5"))))
+ (base32 "1b2f1hik4x3n4n8217sg1k602wqjba8x20r7nsdmmq05qckyprgk"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config))
+ (list config pkg-config))
(inputs
(list libdrm
libx11
@@ -1555,6 +1555,14 @@ quality and performance.")
#~(list (string-append "dummy_drv_video_ladir=" #$output "/lib/dri"))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))
(add-before 'build 'fix-dlopen-paths
(lambda _
(substitute* "va/drm/va_drm_auth_x11.c"
@@ -3181,7 +3189,7 @@ and custom quantization matrices.")
(list python-pysocks
python-websocket-client
python-isodate
- python-lxml-4.7
+ python-lxml
python-pycountry
python-pycryptodome
python-requests
@@ -3618,7 +3626,7 @@ application with @code{obs-gamecapture}.")
(define-public libvdpau
(package
(name "libvdpau")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method git-fetch)
@@ -3628,7 +3636,7 @@ application with @code{obs-gamecapture}.")
(file-name (git-file-name name version))
(sha256
(base32
- "1hc4mcrbr1yhfiy4zfd8wc2iiqbp90z6jswap0jia20vmyk5lqld"))))
+ "1zfbh5q9adzlydpgwq7hl5w1j2b29j7zns6dxf9fp9pvkj23fz5l"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config))