aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm45
1 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f07fe192ed..cc84444491 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1494,14 +1494,14 @@ quality and performance.")
(define-public libva
(package
(name "libva")
- (version "2.13.0")
+ (version "2.15.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/intel/libva/releases/download/"
version "/libva-" version ".tar.bz2"))
(sha256
- (base32 "0q6l193x9whd80sjd5mx8cb7c0fcljb19nhfpla5h49nkzrq7lzs"))))
+ (base32 "1jhy8qzfp4ydbxs9qd9km7k5wq8r4s2vq20r1q07lgld8l4x93i5"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -1513,27 +1513,24 @@ quality and performance.")
mesa
wayland))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'fix-dlopen-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (list
+ ;; Most drivers are in mesa's $prefix/lib/dri, so use that. (Can be
+ ;; overridden at run-time via LIBVA_DRIVERS_PATH.)
+ #:configure-flags
+ #~(list (string-append "--with-drivers-path="
+ (search-input-directory %build-inputs "lib/dri")))
+ ;; However, we can't write to mesa's store directory, so override the
+ ;; following make variable to install the dummy driver to libva's
+ ;; $prefix/lib/dri directory.
+ #:make-flags
+ #~(list (string-append "dummy_drv_video_ladir=" #$output "/lib/dri"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'fix-dlopen-paths
+ (lambda _
(substitute* "va/drm/va_drm_auth_x11.c"
(("\"libva-x11\\.so\\.%d\"")
- (string-append "\"" out "/lib/libva-x11.so.%d\"")))
- #t))))
- ;; Most drivers are in mesa's $prefix/lib/dri, so use that. (Can be
- ;; overridden at run-time via LIBVA_DRIVERS_PATH.)
- #:configure-flags
- (list (string-append "--with-drivers-path="
- (assoc-ref %build-inputs "mesa") "/lib/dri"))
- ;; However, we can't write to mesa's store directory, so override the
- ;; following make variable to install the dummy driver to libva's
- ;; $prefix/lib/dri directory.
- #:make-flags
- (list (string-append "dummy_drv_video_ladir="
- (assoc-ref %outputs "out") "/lib/dri"))))
+ (string-append "\"" #$output "/lib/libva-x11.so.%d\""))))))))
(home-page "https://www.freedesktop.org/wiki/Software/vaapi/")
(synopsis "Video acceleration library")
(description "The main motivation for VA-API (Video Acceleration API) is
@@ -1722,6 +1719,10 @@ operate properly.")
;; The static libraries are 23 MiB
"--disable-static"
+ #$@(if (target-riscv64?)
+ '("--extra-cflags=-fPIC")
+ '())
+
;; Runtime cpu detection is not implemented on
;; MIPS, so we disable some features.
"--disable-mips32r2"
@@ -4380,7 +4381,7 @@ tools for styling them, including a built-in real-time video preview.")
(gst-plugins/selection gst-plugins-bad #:plugins
'("debugutils" "transcode")
#:configure-flags
- '("-Dintrospection=enabled"))
+ #~'("-Dintrospection=enabled"))
gst-libav
gsound
gtk+