aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm79
1 files changed, 45 insertions, 34 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0960410498..e7e61303a9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -100,6 +100,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
@@ -147,6 +148,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnunet)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell-xyz)
@@ -2763,13 +2765,13 @@ the last played position, etc.")
(define-public jellyfin-mpv-shim
(package
(name "jellyfin-mpv-shim")
- (version "2.6.0")
+ (version "2.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jellyfin-mpv-shim" version))
(sha256
- (base32 "1cy2sfv84k5nw8bqy4aa7v0hdawp7gk5s7wq850xizqk0sz7cipp"))))
+ (base32 "0lgs3d6qxxf338mg4mmm4jrkvw1alrks16hx30figwn3dcv5l0qh"))))
(build-system python-build-system)
(arguments
(list
@@ -2835,7 +2837,7 @@ Jellyfin. It has support for various media files without transcoding.")
(define-public gallery-dl
(package
(name "gallery-dl")
- (version "1.25.8")
+ (version "1.27.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mikf/gallery-dl"
@@ -2843,7 +2845,7 @@ Jellyfin. It has support for various media files without transcoding.")
version ".tar.gz"))
(sha256
(base32
- "0dshv4j2gmvd2grwcvp1vsrqsji05r13jvw0cqi9srl66kvqbbga"))))
+ "17gkrz5cw2lfi12x3snzsmxvfk5373klkny1ny9070wp6qgadj6c"))))
(build-system python-build-system)
(inputs (list python-requests ffmpeg))
(home-page "https://github.com/mikf/gallery-dl")
@@ -2962,37 +2964,46 @@ To load this plugin, specify the following option when starting mpv:
(patches (search-patches "libvpx-CVE-2016-2818.patch"
"libvpx-CVE-2023-5217.patch"))))))
-(define-public orf-dl
- (let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
- (revision "1"))
- (package
- (name "orf-dl")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tpoechtrager/orf_dl")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1w413miy01cm7rzb5c6wwfdnc2sqv87cvxwikafgrkswpimvdjsk"))))
- (build-system copy-build-system)
- (arguments
- (list #:install-plan #~`(("orf_dl.php" "bin/orf-dl"))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "orf_dl.php"
- (("ffmpeg")
- (search-input-file inputs "bin/ffmpeg"))))))))
- (inputs (list php ffmpeg))
- (home-page "https://github.com/tpoechtrager/orf_dl")
- (synopsis "Download videos from tvthek.orf.at")
- (description "This package provides a PHP-based command line application
+(define-public orfondl
+ (package
+ (name "orfondl")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/badlogic/orfondl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h1zcxxhvshbc3gkmr33npki6sdjh79haack1cci9k40a0gk144v"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ ;; Delete prebuilt binary file.
+ (delete-file "orfondl")))))
+ (build-system go-build-system)
+ (arguments
+ (list #:go go-1.19
+ #:install-source? #f
+ #:import-path "github.com/badlogic/orfondl"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs import-path #:allow-other-keys)
+ (substitute* (string-append "src/" import-path "/main.go")
+ (("\"ffmpeg\"")
+ (string-append "\""
+ (search-input-file inputs "bin/ffmpeg")
+ "\""))))))))
+ (inputs (list ffmpeg))
+ (home-page "https://github.com/tpoechtrager/orf_dl")
+ (synopsis "Download videos from ORF ON")
+ (description "This package provides a Go-based command line application
to download videos from Austria's national television broadcaster.")
- (license license:gpl2+))))
+ (license license:bsd-3)))
+
+(define-public orf-dl
+ (deprecated-package "orf-dl" orfondl))
(define-public yle-dl
(package
ing.texi?id=0ea096ae23fa81f05ce97e5e61c15647c0a475ec'>doc: Move and rewrite the branching strategy....Christopher Baines 2023-06-08doc: Use the term "Procedure" for definitions....Ludovic Courtès 2023-05-24doc: contributing.texi: Specify recipient via equal sign in 'git send-email -......Felix Lechner 2023-05-07Revert "doc: Update all menus."...Maxim Cournoyer 2023-05-07doc: Update all menus....Maxim Cournoyer 2023-05-07doc: Add some information/recommendation regarding --sysconfdir....Maxim Cournoyer 2023-05-01doc: Simplify contributing section by automating git configuration....Maxim Cournoyer 2023-04-30doc: Add --sysconfdir=/etc to the recommended ./configure....Josselin Poiret 2023-04-03doc: Add a reference to a page explaining consensus decision making....Maxim Cournoyer 2023-03-23doc: Mention Python 2 packages should not be added anymore....Maxim Cournoyer 2023-03-10doc: Sending-a-Patch-Series: Fix URL....Hugo Buddelmeijer