aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm72
1 files changed, 34 insertions, 38 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4280d4fab8..8c9b41384c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1145,8 +1145,8 @@ collaboration using typical untrusted file hosts or services.")
(license license:gpl3+)))
(define-public cgit
- (let ((commit "dbadd856ba0537110338cfe58256b152d01388c0")
- (rev "3"))
+ (let ((commit "b2c939af4bbd24882fcd28aa6b75319ca61c7c5b")
+ (rev "4"))
(package
(name "cgit")
;; Update the ‘git-source’ input as well.
@@ -1158,7 +1158,7 @@ collaboration using typical untrusted file hosts or services.")
(commit commit)))
(sha256
(base32
- "1r9mafmjgi3hknv88a1ypym6qvy2qzs1i3n6z22ddg8q4sb1wjvk"))
+ "09la0xhs9mn8k5j5z5s44pa2fv73akn4lhqpbma08f3xdhjpb3fv"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -1234,9 +1234,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.45.0.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.45.2.tar.xz")
(sha256
- (base32 "0a9ljpjypszj9cxq5lk9zq8bq9v87h9fn9ph3zgyfxk4s05j1b0a"))))
+ (base32 "1nws1vjgj54sv32wxl1h3n1jkcpabqv7a605hhafsby0n5zfigsi"))))
("bash-minimal" ,bash-minimal)
("openssl" ,openssl)
("python" ,python)
@@ -2786,43 +2786,39 @@ any project with more than one developer, is one of Aegis's major functions.")
(define-public tig
(package
(name "tig")
- (version "2.5.8")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/jonas/tig/releases/download/tig-"
- version "/tig-" version ".tar.gz"))
- (sha256
- (base32
- "14b38200bmwvi3030hqnwdsp34854ck3bzncj0wlljnpmr10l3mp"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; TODO: Delete and rebuild doc/*.(1|5|7).
- (for-each delete-file (find-files "doc" "\\.html$"))))))
+ (version "2.5.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonas/tig")
+ (commit (string-append "tig-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m7v6xkvly3cbc5hs7plxdny4r41x3vkx7xylygjva4jcvnz0fjr"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda _
+ (invoke "make" "install-doc")))
+ (add-after 'install 'install-completions
+ (lambda _
+ (let ((share (string-append #$output "/share")))
+ (mkdir-p (string-append share "/bash-completion/completions"))
+ (mkdir-p (string-append share "/zsh/site-functions"))
+ (copy-file "contrib/tig-completion.bash"
+ (string-append share "/bash-completion/completions/tig"))
+ (copy-file "contrib/tig-completion.zsh"
+ (string-append share "/zsh/site-functions/_tig"))))))
+ #:test-target "test"
+ #:tests? #f)) ; tests require access to /dev/tty
(native-inputs
- (list asciidoc xmlto))
+ (list asciidoc autoconf automake docbook-xsl libxml2 pkg-config xmlto))
(inputs
(list ncurses readline))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-doc
- (lambda _
- (invoke "make" "install-doc")))
- (add-after 'install 'install-completions
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (share (string-append out "/share")))
- (mkdir-p (string-append share "/bash-completion/completions"))
- (mkdir-p (string-append share "/zsh/site-functions"))
- (copy-file "contrib/tig-completion.bash"
- (string-append share "/bash-completion/completions/tig"))
- (copy-file "contrib/tig-completion.zsh"
- (string-append share "/zsh/site-functions/_tig"))))))
- #:test-target "test"
- #:tests? #f)) ; tests require access to /dev/tty
(home-page "https://jonas.github.io/tig/")
(synopsis "Ncurses-based text user interface for Git")
(description