aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/telegram.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/telegram.scm')
-rw-r--r--gnu/packages/telegram.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 8efa8f2a0a..18fcc0569b 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -18,7 +18,9 @@
(define-module (gnu packages telegram)
#:use-module (gnu packages)
+ #:use-module (gnu packages animation)
#:use-module (gnu packages assembly)
+ #:use-module (gnu packages check)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
@@ -31,7 +33,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix git-download)
- #:use-module (guix build-system cmake))
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson))
(define-public webrtc-for-telegram-desktop
(let ((commit "fa86fcc00c218813d61a272a56feab55c76a1ab9")
@@ -142,3 +145,37 @@ Telegram project, for its use in telegram desktop client.")
license:gpl3
;; LibSRTP, LibVPx, UsrSCTP and Others
license:bsd-3))))))
+
+(define-public rlottie-for-telegram-desktop
+ (let ((commit "cbd43984ebdf783e94c8303c41385bf82aa36d5b")
+ (revision "671"))
+ (hidden-package
+ (package
+ (inherit rlottie)
+ (version
+ (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/desktop-app/rlottie.git")
+ (commit commit)))
+ (file-name
+ (git-file-name "rlottie-for-telegram-desktop" version))
+ (sha256
+ (base32 "1lxpbgbhps9rmck036mgmiknqrzpjxpas8n7qxykv6pwzn0c8n0c"))))
+ (arguments
+ `(#:configure-flags
+ (list
+ "-Dlog=true"
+ "-Ddumptree=true"
+ "-Dtest=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cxx-flags
+ (lambda _
+ (substitute* "meson.build"
+ (("werror=true")
+ "werror=false"))
+ #t)))))))))
on the content of the file to be displayed and some
+ ;; settings, lesspipe trees to use a large variety of external
+ ;; commands, e.g. rpm, dpkg, vimcolor. We only link the
+ ;; essential ones to avoid this package to pull in all these
+ ;; dependencies which might never ever we used.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file (search-input-file inputs "/bin/file"))
+ (tput (search-input-file inputs "/bin/tput")))
+ (substitute* "sxw2txt"
+ (("^use warnings;" line)
+ (string-append
+ line "\nuse lib '" #$(this-package-input "perl-archive-zip")
+ "/lib/perl5/site_perl';")))
+ (substitute* "lesscomplete"
+ (("file -") (string-append file " -")))
+ (substitute* "lesspipe.sh"
+ (("tput colors")
+ (string-append tput " colors"))
+ (("file -")
+ (string-append file " -")))))))))
(inputs
- (list file ncurses)) ; for tput
+ (list file
+ ncurses ;; for tput
+ perl-archive-zip))
(native-inputs (list perl))
(home-page "https://github.com/wofr06/lesspipe")
(synopsis "Input filter for less")