aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tcsh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tcsh.scm')
-rw-r--r--gnu/packages/tcsh.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/tcsh.scm b/gnu/packages/tcsh.scm
index f582713911..814f2a6321 100644
--- a/gnu/packages/tcsh.scm
+++ b/gnu/packages/tcsh.scm
@@ -58,7 +58,11 @@
(("; other_script.csh") "; /bin/sh other_script.csh"))
;; Now, let's generate the test suite and patch it
(system* "make" "tests/testsuite")
- (substitute* "tests/testsuite" (("/bin/sh") (which "sh"))))
+
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "tests/testsuite"
+ (("/bin/sh") (which "sh")))))
(alist-cons-after
'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)