aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 39b90fad8f..2434a563c2 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -477,10 +477,10 @@ with optional @acronym{TLS, Transport-Level Security} to protect credentials.")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-FHS-file-names
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "scripts/mosh.pl"
- (("/bin/sh")
- (which "sh")))))
+ (("/bin/sh" shell)
+ (search-input-file inputs shell)))))
(add-after 'install 'wrap
(lambda _
;; Make sure 'mosh' can find 'mosh-client' and 'mosh-server'.