aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 70d2aac17a..1dd6dc63f7 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -397,6 +397,40 @@ problems for efficient solution on parallel systems.")
(define-public openfoam
(deprecated-package "openfoam" openfoam-org))
+(define-public openfoam-com
+ ;; This is a fork of 'openfoam-org', maintained separately.
+ (package
+ (inherit openfoam-org)
+ (name "openfoam-com")
+ (version "2212")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://develop.openfoam.com"
+ "/Development/openfoam/-/archive/OpenFOAM-v"
+ version
+ "/openfoam-OpenFOAM-v"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0i9039hfz9gvgymkdjhjvvn5500zha3cpdbpqrzfrfi8lbz10is2"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ (substitute* "etc/bashrc"
+ ;; set same version as guix package
+ (("^export WM_PROJECT_VERSION=.*$")
+ (string-append "export WM_PROJECT_VERSION="
+ ,version "\n")))
+ ;; patch shell paths
+ (substitute* (list "src/OSspecific/POSIX/POSIX.C"
+ "wmake/src/Makefile"
+ "wmake/makefiles/general"
+ "wmake/makefiles/info")
+ (("/bin/sh")
+ "sh"))))))
+ (synopsis "Framework for numerical simulation of fluid flow (from openfoam.com)")
+ (home-page "https://www.openfoam.com")))
+
(define-public open-simulation-interface
(package
(name "open-simulation-interface")
lin Poiret 2021-11-23system: Rework swap space support, add dependencies....Josselin Poiret 2021-11-17gnu: system: Improve location of some configuration warnings....Josselin Poiret 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-02system: Introduce the os-release file....Mathieu Othacehe 2021-10-02system: Add guix-icons to the base packages....Mathieu Othacehe 2021-09-23system: Add xfsprogs to base packages....Tobias Geerinckx-Rice 2021-09-14system: Add trailing newline to /etc/timezone....Ludovic Courtès 2021-08-12system: Accept gexps in 'setuid-programs'....Ludovic Courtès 2021-08-12system: Handle 'setuid-programs' deprecation handling as a field sanitizer....Ludovic Courtès 2021-07-29services: Migrate to <setuid-program>....Brice Waegeneire 2021-07-29services: setuid: More configurable setuid support....Chris Lemmer-Webber 2021-07-09system: Provide mg instead of zile....Mathieu Othacehe 2021-05-11Merge branch 'version-1.3.0'Maxim Cournoyer 2021-05-11gnu: Allow services to install kernel-loadable modules....raid5atemyhomework 2021-05-07system: Add wget to %base-packages-networking....Maxim Cournoyer 2021-01-30services: shepherd: Allow custom 'shepherd' package....Maxime Devos 2021-01-22system: Fix typo in docstring....Ludovic Courtès 2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas 2020-11-26mapped-devices: Allow target to be list of strings....Mikhail Tsykalov