aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8a73c929a1..4088bd3398 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1327,7 +1327,7 @@ and that could be anything you want.")
(add-installed-pythonpath inputs outputs)
(invoke "python" "-m" "pytest" "-vv" "test")))))))
(native-inputs
- (list python-hypothesis-next python-pytest))
+ (list python-hypothesis python-pytest))
(propagated-inputs
(list python-hpack python-hyperframe))
(home-page "https://github.com/python-hyper/h2")
@@ -2169,14 +2169,14 @@ connection to each user.")
(define-public python-tornado-6
(package
(name "python-tornado")
- (version "6.1")
+ (version "6.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tornado" version))
(sha256
(base32
- "14cpzdv6p6qvk6vn02krdh5rcfdi174ifdbr5s6lcnymgcfyiiik"))))
+ "04rwzjfqa31ajz8vvkfcsp1539m8n960msnppxkcckp8plch8qwv"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -3583,15 +3583,15 @@ Python.")
(when tests?
(invoke "pytest" "-v")))))))
(native-inputs
- (list python-mock
- python-pytest
+ (list python-pytest
python-pytest-asyncio
python-pytest-httpserver))
(propagated-inputs
(list python-requests
- python-cookies
- python-six
- python-types-toml))
+ python-toml
+ python-types-toml
+ python-typing-extensions
+ python-urllib3))
(home-page "https://github.com/getsentry/responses")
(synopsis "Utility for mocking out the `requests` Python library")
(description "A utility library for mocking out the `requests` Python