;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . ;;; Commentary: ;;; ;;; This script updates the list of new and updated packages in 'NEWS'. ;;; ;;; Code: (use-modules (gnu) (guix) (guix build utils) ((guix ui) #:select (fill-paragraph)) (srfi srfi-1) (srfi srfi-11) (ice-9 match) (ice-9 rdelim) (ice-9 regex) (ice-9 pretty-print)) (define %header-rx (make-regexp "^\\* Changes in (version )?([0-9.]+) \\(since ([0-9.]+)\\)")) (define (NEWS->versions port) "Return two values: the previous version and the current version as read from PORT, which is an input port on the 'NEWS' file." (let loop () (let ((line (read-line port))) (cond ((eof-object? line) (error "failed to determine previous and current version" port)) ((regexp-exec %header-rx line) => (lambda (match) (values (match:substring match 3) (match:substring match 2)))) (else (loop)))))) (define (skip-to-org-heading port) "Read from PORT until an Org heading is found." (let loop () (let ((next (peek-char port))) (cond ((eqv? next #\*) #t) ((eof-object? next) (error "next heading could not be found")) (else (read-line port) (loop)))))) (define (rewrite-org-section input output heading-rx proc) "Write to OUTPUT the text read from INPUT, but with the first Org section matching HEADING-RX replaced by NEW-HEADING and CONTENTS." (let loop () (let ((line (read-line input))) (cond ((eof-object? line) (error "failed to match heading regexp" heading-rx)) ((regexp-exec heading-rx line) => (lambda (match) (proc match output) (skip-to-org-heading input) (dump-port input output) #t)) (else (display line output) (newline output) (loop)))))) (define (enumeration->paragraph lst) "Turn LST, a list of strings, into a single string that is a ready-to-print paragraph." (fill-paragraph (string-join (sort lst stringparagraph added))))))))) (define (write-packages-updates news-file old new) "Write to NEWS-FILE the list of packages upgraded between OLD and NEW." (let ((upgraded (filter-map (match-lambda ((package . new-version) (match (assoc package old) ((_ . old-version) (and (version>? new-version old-version) (string-append package "@" new-version))) (_ #f)))) new))) (with-atomic-file-replacement news-file (lambda (input output) (rewrite-org-section input output -rw-r--r--gnu/packages/python-web.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c6e760ce35..483abec2d5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3769,25 +3769,24 @@ itself.")
(define-public python-flask-migrate
(package
- (name "python-flask-migrate")
- (version "2.5.3")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-Migrate" version))
- (sha256
- (base32
- "1vip9ww6l18dxffjsggm83k71zkvihxpnhaswpv8klh95s6517d6"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-flask python-alembic python-sqlalchemy
- python-flask-script python-flask-sqlalchemy))