aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ef9f672f1f..c9f122c5c9 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -580,8 +580,9 @@ Python module with the same interface, but (hopefully) faster.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "setup.py" "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "setup.py" "pytest")))))))
(native-inputs
(list python-hypothesis python-pytest python-pytest-runner))
(propagated-inputs